summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-08-30 20:42:00 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-08-30 20:43:02 +0300
commitfce3432e7844bb273af71e494fb449cb6b1eedca (patch)
tree28f91cac75949f5761cb5a54cd0c3f6a8e9fccea /x11-themes/numix-icon-theme/numix-icon-theme-18.07.17.ebuild
parentdev-python/jedi: Tested on py3.7 (diff)
downloadgentoo-fce3432e7844bb273af71e494fb449cb6b1eedca.tar.gz
gentoo-fce3432e7844bb273af71e494fb449cb6b1eedca.tar.bz2
gentoo-fce3432e7844bb273af71e494fb449cb6b1eedca.zip
x11-themes/numix-icon-theme: Initial import
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'x11-themes/numix-icon-theme/numix-icon-theme-18.07.17.ebuild')
-rw-r--r--x11-themes/numix-icon-theme/numix-icon-theme-18.07.17.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11-themes/numix-icon-theme/numix-icon-theme-18.07.17.ebuild b/x11-themes/numix-icon-theme/numix-icon-theme-18.07.17.ebuild
new file mode 100644
index 000000000000..c26f88fd4c35
--- /dev/null
+++ b/x11-themes/numix-icon-theme/numix-icon-theme-18.07.17.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="An official icon theme from the Numix Project"
+HOMEPAGE="https://github.com/numixproject"
+SRC_URI="https://github.com/numixproject/numix-icon-theme/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_install() {
+ insinto /usr/share/icons
+ doins -r Numix{,-Light}
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }