summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-05-05 16:47:38 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-05-05 16:48:11 +0300
commit592543a2c919628e8b2e4a7e71af5e780d0b3d4f (patch)
tree6429ef51c5f3d680aa900e48f7ae41e5c6f43070 /x11-themes/papirus-icon-theme/papirus-icon-theme-20200430.ebuild
parentx11-themes/papirus-icon-theme: mark stable (diff)
downloadgentoo-592543a2c919628e8b2e4a7e71af5e780d0b3d4f.tar.gz
gentoo-592543a2c919628e8b2e4a7e71af5e780d0b3d4f.tar.bz2
gentoo-592543a2c919628e8b2e4a7e71af5e780d0b3d4f.zip
x11-themes/papirus-icon-theme: Version bump (v20200430)
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'x11-themes/papirus-icon-theme/papirus-icon-theme-20200430.ebuild')
-rw-r--r--x11-themes/papirus-icon-theme/papirus-icon-theme-20200430.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-themes/papirus-icon-theme/papirus-icon-theme-20200430.ebuild b/x11-themes/papirus-icon-theme/papirus-icon-theme-20200430.ebuild
new file mode 100644
index 000000000000..72805a2a9317
--- /dev/null
+++ b/x11-themes/papirus-icon-theme/papirus-icon-theme-20200430.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="icon theme for Linux"
+HOMEPAGE="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme"
+SRC_URI="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/icons
+ doins -r ePapirus Papirus{,-Dark,-Light}
+
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }