summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-04-26 20:58:40 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-04-26 21:20:21 +0200
commit3e682645a54e301992df94f0fd1e666523749b6d (patch)
tree994b61f94224849f5f809f6ccbaaf7af80665d39 /x11-themes/pearlgrey-xcursors
parentx11-themes/obsidian-xcursors: drop old version (diff)
downloadgentoo-3e682645a54e301992df94f0fd1e666523749b6d.tar.gz
gentoo-3e682645a54e301992df94f0fd1e666523749b6d.tar.bz2
gentoo-3e682645a54e301992df94f0fd1e666523749b6d.zip
x11-themes/pearlgrey-xcursors: add missing dep
Bug: https://bugs.gentoo.org/758236 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'x11-themes/pearlgrey-xcursors')
-rw-r--r--x11-themes/pearlgrey-xcursors/pearlgrey-xcursors-1.0-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-themes/pearlgrey-xcursors/pearlgrey-xcursors-1.0-r1.ebuild b/x11-themes/pearlgrey-xcursors/pearlgrey-xcursors-1.0-r1.ebuild
new file mode 100644
index 000000000000..9fb85be372ee
--- /dev/null
+++ b/x11-themes/pearlgrey-xcursors/pearlgrey-xcursors-1.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/-xcursors/}"
+
+DESCRIPTION="A simple crispy white-grey xcursor theme"
+HOMEPAGE="https://store.kde.org/p/999829/"
+SRC_URI="mirror://gentoo/11313-${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc x86"
+
+RDEPEND="x11-libs/libXcursor"
+
+src_install() {
+ insinto /usr/share/cursors/xorg-x11/pearlgrey
+ doins -r pearlgrey/cursors
+}
+
+pkg_postinst() {
+ elog "To use this set of cursors, edit or create the file ~/.Xdefaults"
+ elog "and add the following line:"
+ elog "Xcursor.theme: ${MY_PN}"
+ elog
+ elog "You can change the size by adding a line like:"
+ elog "Xcursor.size: 48"
+ elog
+ elog "Also, to globally use this set of mouse cursors edit the file:"
+ elog " ${EROOT}/usr/share/cursors/xorg-x11/default/index.theme"
+ elog "and change the line:"
+ elog " Inherits=[current setting]"
+ elog "to"
+ elog " Inherits=${MY_PN}"
+ elog
+ elog "Note this will be overruled by a user's ~/.Xdefaults file."
+ elog
+
+ ewarn "If you experience flickering, try setting the following line in"
+ ewarn "the Device section of your xorg.conf file:"
+ ewarn " Option \"HWCursor\" \"false\""
+}