summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-06-30 09:52:13 +1000
committerMichael Palimaka <kensington@gentoo.org>2018-06-30 09:52:56 +1000
commit396c12827d50e7bbae77ff6e3d3d61111e8d8c17 (patch)
tree0837186160cfc152147fe417baab8d4209316f07 /x11-themes/smplayer-themes/smplayer-themes-18.6.0.ebuild
parentx11-themes/smplayer-themes: use HTTPS (diff)
downloadgentoo-396c12827d50e7bbae77ff6e3d3d61111e8d8c17.tar.gz
gentoo-396c12827d50e7bbae77ff6e3d3d61111e8d8c17.tar.bz2
gentoo-396c12827d50e7bbae77ff6e3d3d61111e8d8c17.zip
x11-themes/smplayer-themes: version bump 18.6.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'x11-themes/smplayer-themes/smplayer-themes-18.6.0.ebuild')
-rw-r--r--x11-themes/smplayer-themes/smplayer-themes-18.6.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-themes/smplayer-themes/smplayer-themes-18.6.0.ebuild b/x11-themes/smplayer-themes/smplayer-themes-18.6.0.ebuild
new file mode 100644
index 000000000000..25a6b959aaea
--- /dev/null
+++ b/x11-themes/smplayer-themes/smplayer-themes-18.6.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="Icon themes for smplayer"
+HOMEPAGE="https://www.smplayer.info/"
+SRC_URI="mirror://sourceforge/smplayer/${P}.tar.bz2"
+
+LICENSE="CC-BY-2.5 CC-BY-SA-2.5 CC-BY-SA-3.0 CC0-1.0 GPL-2 GPL-3+ LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:5"
+RDEPEND="media-video/smplayer"
+
+src_prepare() {
+ default
+
+ # bug 544108
+ sed -i -e "s| rcc| \"$(qt5_get_bindir)\"/rcc|" themes/Makefile || die
+
+ # bug 544160
+ sed -i -e 's/make/$(MAKE)/' Makefile || die
+}
+
+src_install() {
+ rm themes/Makefile || die
+ insinto /usr/share/smplayer
+ doins -r themes
+ dodoc Changelog README.txt
+}