summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-11 20:21:56 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-11 20:46:53 +0100
commit487ba6b7e02c75746c270c5d49f62fd67c1507ed (patch)
treead8c125a2f43116ef242862daed09ccda82692bb /x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r2.ebuild
parentx11-themes/nuvox: Depend on virtual/imagemagick-tools (diff)
downloadgentoo-487ba6b7e02c75746c270c5d49f62fd67c1507ed.tar.gz
gentoo-487ba6b7e02c75746c270c5d49f62fd67c1507ed.tar.bz2
gentoo-487ba6b7e02c75746c270c5d49f62fd67c1507ed.zip
x11-themes/tango-icon-theme-extras: Depend on virtual/imagemagick-tools
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3907
Diffstat (limited to 'x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r2.ebuild')
-rw-r--r--x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r2.ebuild b/x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r2.ebuild
new file mode 100644
index 000000000000..3106a3d38f03
--- /dev/null
+++ b/x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="Tango icons for iPod Digital Audio Player devices and the Dell Pocket DJ DAP"
+HOMEPAGE="http://tango.freedesktop.org"
+SRC_URI="http://tango.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="CC-BY-SA-2.5"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="png"
+
+RDEPEND=">=x11-themes/tango-icon-theme-0.8.90"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=gnome-base/librsvg-2.34
+ virtual/imagemagick-tools[png?]
+ >=x11-misc/icon-naming-utils-0.8.90"
+
+RESTRICT="binchecks strip"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-graphicsmagick.patch
+ epatch "${FILESDIR}"/${P}-MKDIR_P.patch
+ sed -i -e '/svgconvert_prog/s:rsvg:&-convert:' configure{,.ac} || die #413183
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable png png-creation) \
+ $(use_enable png icon-framing)
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }