summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-01-01 20:16:54 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-01-02 02:55:44 -0800
commit0c231445a4bc46635ee21cddf35d40e787b5f76e (patch)
treeab256fee336e1a3e64305306b3faf84118e93944 /x11-themes/tela-icon-theme/tela-icon-theme-20211225.ebuild
parentx11-themes/tela-icon-theme: initial import (diff)
downloadgentoo-0c231445a4bc46635ee21cddf35d40e787b5f76e.tar.gz
gentoo-0c231445a4bc46635ee21cddf35d40e787b5f76e.tar.bz2
gentoo-0c231445a4bc46635ee21cddf35d40e787b5f76e.zip
x11-themes/tela-icon-theme: make standard theme optional
seems it's not actually required for other variants to function Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'x11-themes/tela-icon-theme/tela-icon-theme-20211225.ebuild')
-rw-r--r--x11-themes/tela-icon-theme/tela-icon-theme-20211225.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/x11-themes/tela-icon-theme/tela-icon-theme-20211225.ebuild b/x11-themes/tela-icon-theme/tela-icon-theme-20211225.ebuild
index 26d159c90dea..cb8d15b5cbfa 100644
--- a/x11-themes/tela-icon-theme/tela-icon-theme-20211225.ebuild
+++ b/x11-themes/tela-icon-theme/tela-icon-theme-20211225.ebuild
@@ -7,8 +7,8 @@ EAPI=8
MY_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
MY_PN="${PN/t/T}"
-# standard is always installed
-MY_COLOR_VARIANTS=( black blue brown green grey orange pink purple red yellow manjaro ubuntu )
+# standard comes first
+MY_COLOR_VARIANTS=( standard black blue brown green grey orange pink purple red yellow manjaro ubuntu )
inherit xdg
@@ -26,7 +26,9 @@ fi
LICENSE="GPL-3+"
SLOT="0"
-IUSE="${MY_COLOR_VARIANTS[*]}"
+IUSE="${MY_COLOR_VARIANTS[*]/standard/+standard}"
+
+REQUIRED_USE="|| ( ${MY_COLOR_VARIANTS[*]} )"
BDEPEND="app-shells/bash"
@@ -38,7 +40,6 @@ src_prepare() {
src_install() {
local v variants=(
- standard
$(
for v in ${MY_COLOR_VARIANTS[@]}; do
usev ${v}