summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-07-08 10:09:08 +0200
committerPacho Ramos <pacho@gentoo.org>2021-07-08 10:09:08 +0200
commit86835c586f000daccb4673803893e5153e6c3f07 (patch)
tree9734c0ce0d2434e844e604ebd554ba5815ae2d36 /x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-21.04.1.ebuild
parentx11-themes/fedora-backgrounds: Stabilize (diff)
downloadgentoo-86835c586f000daccb4673803893e5153e6c3f07.tar.gz
gentoo-86835c586f000daccb4673803893e5153e6c3f07.tar.bz2
gentoo-86835c586f000daccb4673803893e5153e6c3f07.zip
x11-themes/ubuntu-wallpapers: Bump to 21.04.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-21.04.1.ebuild')
-rw-r--r--x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-21.04.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-21.04.1.ebuild b/x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-21.04.1.ebuild
new file mode 100644
index 000000000000..44e99c435c75
--- /dev/null
+++ b/x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-21.04.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Ubuntu wallpapers"
+HOMEPAGE="https://launchpad.net/ubuntu/+source/ubuntu-wallpapers"
+MY_P="${PN}_${PV}"
+SRC_URI="mirror://ubuntu/pool/main/u/${PN}/${MY_P}.orig.tar.gz"
+
+# Review COPYING file for updates
+LICENSE="CC-BY-SA-3.0"
+
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+BDEPEND=""
+
+S="${WORKDIR}/${MY_P/_/-}"
+
+SLOT="0"
+
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ insinto /usr/share/backgrounds
+ doins *.jpg *.png
+
+ insinto /usr/share/backgrounds/contest
+ doins contest/*.xml
+
+ for i in *.xml.in; do
+ insinto /usr/share/gnome-background-properties
+ newins ${i} ${i/.in/}
+ done
+
+ einstalldocs
+}