summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-10-09 00:55:35 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2016-10-09 00:58:05 +0200
commitd0dcfd284ad3cdd8d8ff66f22e5223824260901d (patch)
treec902f209f00b1a30322006ab0d5e0640baea75b0 /x11-themes/vertex-theme/vertex-theme-20160329.ebuild
parentx11-themes/zukitwo-shell: add transition bump to x11-themes/zuki-themes (diff)
downloadgentoo-d0dcfd284ad3cdd8d8ff66f22e5223824260901d.tar.gz
gentoo-d0dcfd284ad3cdd8d8ff66f22e5223824260901d.tar.bz2
gentoo-d0dcfd284ad3cdd8d8ff66f22e5223824260901d.zip
x11-themes/vertex-theme: initial ebuild
Gentoo-bug: 550732 Package-Manager: portage-2.3.1
Diffstat (limited to 'x11-themes/vertex-theme/vertex-theme-20160329.ebuild')
-rw-r--r--x11-themes/vertex-theme/vertex-theme-20160329.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-themes/vertex-theme/vertex-theme-20160329.ebuild b/x11-themes/vertex-theme/vertex-theme-20160329.ebuild
new file mode 100644
index 000000000000..15977002bb32
--- /dev/null
+++ b/x11-themes/vertex-theme/vertex-theme-20160329.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Vertex theme for GTK+ based desktops"
+HOMEPAGE="https://github.com/horst3180/vertex-theme"
+SRC_URI="https://github.com/horst3180/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cinnamon gnome-shell mate xfce"
+
+RDEPEND="
+ x11-themes/gnome-themes-standard
+ x11-themes/gtk-engines-murrine
+ cinnamon? ( >=x11-libs/gtk+-3.20:3 )
+ gnome-shell? ( >=x11-libs/gtk+-3.20:3 )
+"
+DEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Do not let configure try to figure out gtk+:3 version installed
+ # See also https://github.com/horst3180/arc-theme/issues/436 and 484
+ "${FILESDIR}"/configure-gtk3-version.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-unity \
+ --enable-gtk2 \
+ --enable-gtk3 \
+ --with-gnome=3.20 \
+ $(use_enable cinnamon) \
+ $(use_enable gnome-shell) \
+ $(use_enable mate metacity) \
+ $(use_enable xfce xfwm)
+}