summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-10-11 23:00:28 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2019-10-11 23:00:28 +0200
commitde38bb718d86294c2ba0e9719606b6bec2ec1111 (patch)
tree1fdf4c267fe5910cde6aa92f60ff23f209c40530 /x11-themes/windowmaker-themes/windowmaker-themes-0.1-r1.ebuild
parentapp-crypt/veracrypt: bump to 1.24 (diff)
downloadgentoo-de38bb718d86294c2ba0e9719606b6bec2ec1111.tar.gz
gentoo-de38bb718d86294c2ba0e9719606b6bec2ec1111.tar.bz2
gentoo-de38bb718d86294c2ba0e9719606b6bec2ec1111.zip
x11-themes/windowmaker-themes: ebuild rewrite and EAPI bump
Bump from EAPI 0 to 7 Remove duplicate themes Upstream site is gone, mirror the themes in single tarball Closes: https://bugs.gentoo.org/697148 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-themes/windowmaker-themes/windowmaker-themes-0.1-r1.ebuild')
-rw-r--r--x11-themes/windowmaker-themes/windowmaker-themes-0.1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-themes/windowmaker-themes/windowmaker-themes-0.1-r1.ebuild b/x11-themes/windowmaker-themes/windowmaker-themes-0.1-r1.ebuild
new file mode 100644
index 000000000000..a6be1af95404
--- /dev/null
+++ b/x11-themes/windowmaker-themes/windowmaker-themes-0.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# TODO: Break themes up by author and into sub-dirs named after
+# the author
+
+DESCRIPTION="Collection of Window Maker themes"
+HOMEPAGE="http://www.windowmaker.org/"
+# Original site: http://gentoo.asleep.net/windowmaker-themes
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="offensive"
+
+DEPEND=""
+RDEPEND="x11-wm/windowmaker"
+BDEPEND=""
+
+src_prepare() {
+ MY_OFFENSIVE="3white Anguish"
+ if ! use offensive ; then
+ for j in ${MY_OFFENSIVE} ; do
+ rm -rf ${MY_OFFENSIVE}.themed
+ done
+ fi
+
+ default
+}
+
+src_install() {
+ insinto /usr/share/WindowMaker/Themes
+ doins -r .
+}
+
+pkg_postinst() {
+ einfo "The Window Maker themes downloaded are by the following artists:"
+ einfo "A.Sleep - http://www.asleep.net/"
+ einfo "Largo - http://largo.windowmaker.org/"
+ einfo "Hadess - http://www.hadess.net/"
+ einfo "jenspen - http://themes.freshmeat.net/~jenspen/"
+}