summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-06-20 20:43:25 +0200
committerPacho Ramos <pacho@gentoo.org>2018-06-20 20:46:52 +0200
commit92588b49bef5cfe6f7e16333160d272753c42eb6 (patch)
treed136ebbb5168999dd3f6683fe6914ec77cd75b77 /x11-themes/wm-icons/wm-icons-0.4.0.ebuild
parentdev-python/flask-wtf: Support Python 3.6, fix dependencies (diff)
downloadgentoo-92588b49bef5cfe6f7e16333160d272753c42eb6.tar.gz
gentoo-92588b49bef5cfe6f7e16333160d272753c42eb6.tar.bz2
gentoo-92588b49bef5cfe6f7e16333160d272753c42eb6.zip
x11-themes/wm-icons: Fix install (#655174 by Kevin Korb)
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'x11-themes/wm-icons/wm-icons-0.4.0.ebuild')
-rw-r--r--x11-themes/wm-icons/wm-icons-0.4.0.ebuild28
1 files changed, 19 insertions, 9 deletions
diff --git a/x11-themes/wm-icons/wm-icons-0.4.0.ebuild b/x11-themes/wm-icons/wm-icons-0.4.0.ebuild
index d6932e13238d..641611583e18 100644
--- a/x11-themes/wm-icons/wm-icons-0.4.0.ebuild
+++ b/x11-themes/wm-icons/wm-icons-0.4.0.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit readme.gentoo-r1
DESCRIPTION="A Large Assortment of Beautiful Themed Icons, Created with FVWM in mind"
HOMEPAGE="http://wm-icons.sourceforge.net/"
@@ -12,11 +13,24 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
IUSE=""
-RDEPEND="virtual/awk dev-lang/perl"
-DEPEND="${RDEPEND} sys-devel/autoconf sys-devel/automake sys-apps/sed"
+RDEPEND="
+ virtual/awk
+ dev-lang/perl
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-build.patch )
+
+DOC_CONTENTS="
+ Users can use the wm-icons-config utility to create aliases in their
+ home directory, FVWM users can then set this in their ImagePath.
+ Sample configurations for fvwm1, fvwm2, fvwm95 and scwm are available in
+ /usr/share/wm-icons
+"
src_configure() {
- econf --enable-all-sets \
+ econf \
+ --enable-all-sets \
--enable-icondir="${EPREFIX}"/usr/share/icons/wm-icons
}
@@ -28,13 +42,9 @@ src_install() {
"${ED%/}/usr/bin/wm-icons-config" --force --user-dir="${ED%/}/usr/share/icons/wm-icons" --defaults || die
einstalldocs
+ readme.gentoo_create_doc
}
pkg_postinst() {
- einfo "Users can use the wm-icons-config utility to create aliases in their"
- einfo "home directory, FVWM users can then set this in their ImagePath"
- einfo
- einfo "Sample configurations for fvwm1, fvwm2, fvwm95 and scwm are available in"
- einfo "/usr/share/wm-icons"
- einfo
+ readme.gentoo_print_elog
}