summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-12-22 17:20:32 +0000
committerMarek Szuba <marecki@gentoo.org>2020-12-22 17:32:17 +0000
commit205b0f865a75f324a828a7c8725f8893b76cecfb (patch)
tree7a7984034a733080723bfaf09fc01e72180b0334 /x11-themes
parentmedia-video/obs-studio: migrate to lua-single.eclass (diff)
downloadgentoo-205b0f865a75f324a828a7c8725f8893b76cecfb.tar.gz
gentoo-205b0f865a75f324a828a7c8725f8893b76cecfb.tar.bz2
gentoo-205b0f865a75f324a828a7c8725f8893b76cecfb.zip
x11-themes/gtk-engines-2.20.2-r100: make USE=lua work for non-native ABIs
As predicted, I have ended up simply patching configure. Closes: https://bugs.gentoo.org/752888 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-engines/gtk-engines-2.20.2-r100.ebuild20
1 files changed, 7 insertions, 13 deletions
diff --git a/x11-themes/gtk-engines/gtk-engines-2.20.2-r100.ebuild b/x11-themes/gtk-engines/gtk-engines-2.20.2-r100.ebuild
index 597dc742bc9a..39c7e74458e0 100644
--- a/x11-themes/gtk-engines/gtk-engines-2.20.2-r100.ebuild
+++ b/x11-themes/gtk-engines/gtk-engines-2.20.2-r100.ebuild
@@ -42,25 +42,19 @@ PATCHES=(
src_prepare() {
gnome2_src_prepare
+ # pkgconfig wrapper set up by lua-single.eclass is not multilib-compatible
+ # at present so point Autoconf directly to the correct implementation.
+ # We patch configure rather than configure.ac because running 'eautoreconf'
+ # results for some reason in corrupted test Makefiles.
+ sed -i -e "s|\"lua\"|\"${ELUA}\"|g" configure || die
}
multilib_src_configure() {
local confopts=(
--enable-animation
+ $(use_enable lua)
+ $(use_with lua system-lua)
)
- # TODO: fix system-lua detection so that it works for non-native ABIs,
- # native builds rely on the pkgconfig wrapper set up by lua-single.eclass
- # but that wrapper is not multilib-compatible.
- if multilib_is_native_abi; then
- confopts+=(
- $(use_enable lua)
- $(use_with lua system-lua)
- )
- else
- confopts+=(
- --disable-lua
- )
- fi
ECONF_SOURCE=${S} gnome2_src_configure "${confopts[@]}"
}