summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-08-23 12:18:54 +0200
committerPacho Ramos <pacho@gentoo.org>2023-08-23 12:19:39 +0200
commit26661ae82f43f6db1e2e5169c14749c2e81e8a94 (patch)
treef010cea402212d711255953dd677ab274e43d06c /x11-themes
parentdev-libs/libclc: Add 17.0.0_rc3 (diff)
downloadgentoo-26661ae82f43f6db1e2e5169c14749c2e81e8a94.tar.gz
gentoo-26661ae82f43f6db1e2e5169c14749c2e81e8a94.tar.bz2
gentoo-26661ae82f43f6db1e2e5169c14749c2e81e8a94.zip
x11-themes/QGnomePlatform: revert upstream change breaking theming
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/QGnomePlatform/QGnomePlatform-0.9.2-r1.ebuild42
-rw-r--r--x11-themes/QGnomePlatform/files/QGnomePlatform-0.9.2-gtk3-conflict.patch57
2 files changed, 99 insertions, 0 deletions
diff --git a/x11-themes/QGnomePlatform/QGnomePlatform-0.9.2-r1.ebuild b/x11-themes/QGnomePlatform/QGnomePlatform-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..8fc6b823f8b8
--- /dev/null
+++ b/x11-themes/QGnomePlatform/QGnomePlatform-0.9.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="A Qt Platform Theme aimed to accommodate GNOME settings"
+HOMEPAGE="https://github.com/FedoraQt/QGnomePlatform"
+SRC_URI="https://github.com/FedoraQt/QGnomePlatform/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="minimal wayland"
+
+RDEPEND="
+ dev-qt/qtdbus:5=
+ >=dev-qt/qtquickcontrols2-5.15.2:5=
+ >=dev-qt/qtwidgets-5.15.2:5=
+ !minimal? ( kde-frameworks/qqc2-desktop-style:5= )
+ wayland? ( dev-qt/qtwayland:5= )
+ gnome-base/gsettings-desktop-schemas
+ sys-apps/xdg-desktop-portal
+ x11-libs/gtk+:3
+ >=x11-themes/adwaita-qt-1.4.2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
+
+src_prepare() {
+ # https://github.com/FedoraQt/QGnomePlatform/pull/150#issuecomment-1689693729
+ eapply -R "${FILESDIR}/${P}-gtk3-conflict.patch"
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT6=false
+ -DDISABLE_DECORATION_SUPPORT="$(usex wayland false true)"
+ )
+ cmake_src_configure
+}
diff --git a/x11-themes/QGnomePlatform/files/QGnomePlatform-0.9.2-gtk3-conflict.patch b/x11-themes/QGnomePlatform/files/QGnomePlatform-0.9.2-gtk3-conflict.patch
new file mode 100644
index 000000000000..29a87aee6f61
--- /dev/null
+++ b/x11-themes/QGnomePlatform/files/QGnomePlatform-0.9.2-gtk3-conflict.patch
@@ -0,0 +1,57 @@
+From d86d6baab74c3e69094083715ffef4aef2e516dd Mon Sep 17 00:00:00 2001
+From: Jan Grulich <jgrulich@redhat.com>
+Date: Fri, 11 Aug 2023 13:45:41 +0200
+Subject: [PATCH] Do not use "gtk3" key to avoid conflict with QGtkStyle from
+ Qt upstream (#150)
+
+---
+ src/decoration/decorationplugin.cpp | 2 +-
+ src/decoration/qgnomeplatformdecoration.json | 2 +-
+ src/theme/platformplugin.cpp | 2 +-
+ src/theme/qgnomeplatformtheme.json | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/decoration/decorationplugin.cpp b/src/decoration/decorationplugin.cpp
+index 40737e4..fb367df 100644
+--- a/src/decoration/decorationplugin.cpp
++++ b/src/decoration/decorationplugin.cpp
+@@ -23,7 +23,7 @@
+ QWaylandAbstractDecoration *QGnomePlatformDecorationPlugin::create(const QString &key, const QStringList &paramList)
+ {
+ Q_UNUSED(paramList)
+- if (key == "gnome" || key == "gtk3" || key == "qgnomeplatform")
++ if (key == "gnome" || key == "qgnomeplatform")
+ return new QGnomePlatformDecoration();
+ return nullptr;
+ }
+diff --git a/src/decoration/qgnomeplatformdecoration.json b/src/decoration/qgnomeplatformdecoration.json
+index 891c3e4..a4a854d 100644
+--- a/src/decoration/qgnomeplatformdecoration.json
++++ b/src/decoration/qgnomeplatformdecoration.json
+@@ -1,3 +1,3 @@
+ {
+- "Keys": [ "gnome", "gtk3", "qgnomeplatform" ]
++ "Keys": [ "gnome", "qgnomeplatform" ]
+ }
+diff --git a/src/theme/platformplugin.cpp b/src/theme/platformplugin.cpp
+index 9908bee..f43ff4e 100644
+--- a/src/theme/platformplugin.cpp
++++ b/src/theme/platformplugin.cpp
+@@ -27,7 +27,7 @@ QGnomePlatformThemePlugin::QGnomePlatformThemePlugin(QObject *parent)
+ QPlatformTheme *QGnomePlatformThemePlugin::create(const QString &key, const QStringList &paramList)
+ {
+ Q_UNUSED(paramList)
+- if (key == "gnome" || key == "gtk3" || key == "qgnomeplatform")
++ if (key == "gnome" || key == "qgnomeplatform")
+ return new QGnomePlatformTheme();
+ return nullptr;
+ }
+diff --git a/src/theme/qgnomeplatformtheme.json b/src/theme/qgnomeplatformtheme.json
+index 891c3e4..a4a854d 100644
+--- a/src/theme/qgnomeplatformtheme.json
++++ b/src/theme/qgnomeplatformtheme.json
+@@ -1,3 +1,3 @@
+ {
+- "Keys": [ "gnome", "gtk3", "qgnomeplatform" ]
++ "Keys": [ "gnome", "qgnomeplatform" ]
+ }