summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-11-02 11:29:57 +0000
committerJames Le Cuirot <chewi@gentoo.org>2019-11-02 11:50:38 +0000
commit390c169f15584a52facdbfa78a2e91f17b8c2397 (patch)
tree6fc6ebd43be525bbdb4c89090fdc52c09b650ea0 /x11-themes
parentprofiles: Mask x11-themes/arc-theme[gnome-shell] in SELinux profiles (diff)
downloadgentoo-390c169f15584a52facdbfa78a2e91f17b8c2397.tar.gz
gentoo-390c169f15584a52facdbfa78a2e91f17b8c2397.tar.bz2
gentoo-390c169f15584a52facdbfa78a2e91f17b8c2397.zip
x11-themes/arc-theme: Version bump to 20190917
Bug: https://bugs.gentoo.org/699092 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/arc-theme/Manifest2
-rw-r--r--x11-themes/arc-theme/arc-theme-20190917.ebuild87
-rw-r--r--x11-themes/arc-theme/metadata.xml2
3 files changed, 90 insertions, 1 deletions
diff --git a/x11-themes/arc-theme/Manifest b/x11-themes/arc-theme/Manifest
index c23a91d5bf66..a52dc02a5ac8 100644
--- a/x11-themes/arc-theme/Manifest
+++ b/x11-themes/arc-theme/Manifest
@@ -1,2 +1,4 @@
DIST arc-theme-20190330-pngs.tar.xz 87632 BLAKE2B a860abe61d98c1ba2c7e13d21cb24e74e110b4e075eb53fc0d34b5e84eeed345a9b32e948e673b445d15e74b4c27991408139861b2d80124c8d97e417ecb3fb3 SHA512 0421530b99ebbe286e111477a056e17e7aa23a63e8c7d63443c4ffcdcb053f191a05fd16e54d9fa4efa9d1c870ff500ffb0c519d6604d6d7294cc1da711de5ba
DIST arc-theme-20190330.tar.xz 227936 BLAKE2B 35815019884c55ce2d22dbb2d78892c00b35839b017fb7f0c1e9e1f1bad1bf94703e0c15205045eed96add556381c28fdd702c7657226fd75492304abaafd41d SHA512 ac4f1bde028e027314004999502dcc914abf6070ffd4345021df486084de2c943e6c110776b3b6af55143962a40b368c060a11754ffaf30300b87cb923bc55b9
+DIST arc-theme-20190917-pngs.tar.xz 87664 BLAKE2B 8f4cd7cf4eaeef6e71113178776e35f81df1c7a86c5a4e1727ddac9e2c18f81ff51f0b8c2ca578c176fddb969fcbdef7135080c1a8851f56e1b1a33d8c2b86e6 SHA512 5ded6dd5f0c7067c8abefef8fae4620caf795f10b5fe46c30ab7b430379f3b3e2eb27ec85c752bb4a77288a640bcf6a5f4d60e19a97f96af1b31143014afde37
+DIST arc-theme-20190917.tar.xz 308592 BLAKE2B 0ca3b6bb9c501891243755984799c404645a524fd5e65e6ed5d509d3c3b0b54d60a2219030b86d6e8a19a12106da832ff4a4fcd35ff1f02766b57d104e9e642b SHA512 da3e98e696160542fc77678193ff4fdeecc1cab7b4c1ec57e1bd850486a80547e1d688c9784f5ef422f097449f1105c071a3ff917c25a6a315fe970bedf10c6f
diff --git a/x11-themes/arc-theme/arc-theme-20190917.ebuild b/x11-themes/arc-theme/arc-theme-20190917.ebuild
new file mode 100644
index 000000000000..99e91d871927
--- /dev/null
+++ b/x11-themes/arc-theme/arc-theme-20190917.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# USE="-* gtk2 gtk3 xfce" ebuild ${P}.ebuild clean compile
+# cd ~portage/x11-themes/${P}/work
+# make -j -C ${P}/common/gtk-3.0/3.18
+# find ${P}/common/{gtk-2.0,gtk-3.0/3.*,xfwm4} -name "*.png" ! -path "*/menubar-toolbar/*" | xargs tar Jcvf /usr/portage/distfiles/${P}-pngs.tar.xz
+
+inherit autotools
+
+DESCRIPTION="A flat theme with transparent elements for GTK+3, GTK+2 and GNOME Shell"
+HOMEPAGE="https://github.com/arc-design/arc-theme"
+SRC_URI="https://github.com/arc-design/${PN}/releases/download/${PV}/${P}.tar.xz
+ pre-rendered? ( https://dev.gentoo.org/~chewi/distfiles/${P}-pngs.tar.xz )"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="cinnamon gnome-shell +gtk2 +gtk3 mate +pre-rendered xfce"
+
+SASSC_DEPEND="
+ dev-lang/sassc
+"
+
+SVG_DEPEND="
+ !pre-rendered? (
+ media-gfx/inkscape
+ media-gfx/optipng
+ )
+"
+
+# Supports various GTK+3 versions and uses pkg-config to determine which
+# set of files to install. Updates will break it but only this fix will
+# help. See https://github.com/horst3180/arc-theme/pull/436. The same
+# applies to GNOME Shell but I don't know whether that's fixable.
+BDEPEND="
+ cinnamon? (
+ ${SASSC_DEPEND}
+ )
+ gnome-shell? (
+ ${SASSC_DEPEND}
+ >=gnome-base/gnome-shell-3.18
+ )
+ gtk2? (
+ ${SVG_DEPEND}
+ )
+ gtk3? (
+ ${SASSC_DEPEND}
+ ${SVG_DEPEND}
+ virtual/pkgconfig
+ >=x11-libs/gtk+-3.18:3
+ )
+ xfce? (
+ ${SVG_DEPEND}
+ )
+"
+
+# gnome-themes-standard is only needed by GTK+2 for the Adwaita
+# engine. This engine is built into GTK+3.
+RDEPEND="
+ gtk2? (
+ x11-themes/gnome-themes-standard
+ x11-themes/gtk-engines-murrine
+ )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use pre-rendered &&
+ export INKSCAPE="${BROOT}"/bin/false OPTIPNG="${BROOT}"/bin/false
+
+ econf \
+ --disable-openbox \
+ --disable-plank \
+ --disable-unity \
+ $(use_enable cinnamon) \
+ $(use_enable gtk2) \
+ $(use_enable gtk3) \
+ $(use_enable gnome-shell) \
+ $(use_enable mate metacity) \
+ $(use_enable xfce xfwm)
+}
diff --git a/x11-themes/arc-theme/metadata.xml b/x11-themes/arc-theme/metadata.xml
index ac2d19205792..cec57cceb9c0 100644
--- a/x11-themes/arc-theme/metadata.xml
+++ b/x11-themes/arc-theme/metadata.xml
@@ -6,7 +6,7 @@
<name>James Le Cuirot</name>
</maintainer>
<upstream>
- <remote-id type="github">horst3180/arc-theme</remote-id>
+ <remote-id type="github">arc-design/arc-theme</remote-id>
</upstream>
<use>
<flag name="cinnamon">Install theme for <pkg>gnome-extra/cinnamon</pkg></flag>