summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-24 16:28:59 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-24 16:46:30 +0100
commit3a22e1e18d5239c0cb3d9545a89188aa9dd3cd7c (patch)
tree455e73a056598f1089c39c390ec86f66c556f1b7 /x11-themes
parentnet-misc/memcached: Stabilize 1.6.9 s390, #764131 (diff)
downloadgentoo-3a22e1e18d5239c0cb3d9545a89188aa9dd3cd7c.tar.gz
gentoo-3a22e1e18d5239c0cb3d9545a89188aa9dd3cd7c.tar.bz2
gentoo-3a22e1e18d5239c0cb3d9545a89188aa9dd3cd7c.zip
x11-themes/gtk-engines-unico: EAPI-7++, autotools-multilib--
Drop superfluous eutils. Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-engines-unico/gtk-engines-unico-1.0.3_pre20140109-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-unico/gtk-engines-unico-1.0.3_pre20140109-r1.ebuild b/x11-themes/gtk-engines-unico/gtk-engines-unico-1.0.3_pre20140109-r1.ebuild
new file mode 100644
index 000000000000..f2451ccc2fa1
--- /dev/null
+++ b/x11-themes/gtk-engines-unico/gtk-engines-unico-1.0.3_pre20140109-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=${PN/gtk-engines-}
+MY_PV=${PV/_pre/+14.04.}
+MY_P=${MY_PN}_${MY_PV}
+inherit autotools multilib-minimal
+
+DESCRIPTION="The Unico GTK+ 3.x theming engine"
+HOMEPAGE="https://launchpad.net/unico"
+SRC_URI="https://launchpad.net/ubuntu/+archive/primary/+files/${MY_P}.orig.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.26:2[${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.10[glib,${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-3.5.2:3[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # $(use_enable debug) controls CPPFLAGS -D_DEBUG and -DNDEBUG but they are currently
+ # unused in the code itself.
+ local myeconfargs=(
+ --disable-static
+ --disable-debug
+ --disable-maintainer-flags
+ )
+ ECONF_SOURCE=${S} econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name '*.la' -delete || die
+}