summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-24 12:53:21 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-24 12:53:21 +0100
commit52c93764c13cdfd87b7a424c811e1ff7e9d89fab (patch)
treeaba235b7822ed062073f82fc206bbefece9d2937 /x11-themes
parentx11-themes/human-icon-theme: Port to EAPI 7 (diff)
downloadgentoo-52c93764c13cdfd87b7a424c811e1ff7e9d89fab.tar.gz
gentoo-52c93764c13cdfd87b7a424c811e1ff7e9d89fab.tar.bz2
gentoo-52c93764c13cdfd87b7a424c811e1ff7e9d89fab.zip
x11-themes/nimbus: Port to EAPI 7
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/nimbus/files/nimbus-0.1.7-fix-themes.patch43
-rw-r--r--x11-themes/nimbus/nimbus-0.1.7-r1.ebuild62
2 files changed, 74 insertions, 31 deletions
diff --git a/x11-themes/nimbus/files/nimbus-0.1.7-fix-themes.patch b/x11-themes/nimbus/files/nimbus-0.1.7-fix-themes.patch
new file mode 100644
index 000000000000..8135bb1dfd2c
--- /dev/null
+++ b/x11-themes/nimbus/files/nimbus-0.1.7-fix-themes.patch
@@ -0,0 +1,43 @@
+- Tango is deprecated
+- Encoding= key is obsolete
+
+--- a/dark-index.theme.in
++++ b/dark-index.theme.in
+@@ -2,7 +2,6 @@
+ Type=X-GNOME-Metatheme
+ _Name=Dark Nimbus
+ _Comment=Sun Microsystems, Inc. alternative theme
+-Encoding=UTF-8
+
+ [X-GNOME-Metatheme]
+ GtkTheme=dark-nimbus
+--- a/icons/index.theme.in
++++ b/icons/index.theme.in
+@@ -1,6 +1,6 @@
+ [Icon Theme]
+ Name=nimbus
+-Inherits=Tango
++Inherits=gnome,Tango
+ Directories=12x12/actions,12x12/emblems,12x12/places,16x16/actions,16x16/apps,16x16/categories,16x16/devices,16x16/emblems,16x16/places,16x16/mimetypes,16x16/status,20x20/status,24x24/actions,24x24/animations,24x24/apps,24x24/categories,24x24/devices,24x24/emblems,24x24/places,24x24/mimetypes,24x24/status,32x32/actions,32x32/apps,32x32/categories,32x32/devices,32x32/emblems,32x32/places,32x32/mimetypes,32x32/status,36x36/actions,36x36/animations,36x36/apps,36x36/categories,36x36/devices,36x36/places,36x36/mimetypes,48x48/actions,48x48/animations,48x48/apps,48x48/categories,48x48/devices,48x48/places,48x48/mimetypes,48x48/status,48x48/emblems,72x72/apps,72x72/categories,72x72/places,72x72/mimetypes,96x96/apps,96x96/categories,96x96/devices,96x96/places,96x96/mimetypes,192x192/apps,192x192/categories,192x192/devices,192x192/places,192x192/mimetypes
+ Example=user-desktop
+
+--- a/index.theme.in
++++ b/index.theme.in
+@@ -2,7 +2,6 @@
+ Type=X-GNOME-Metatheme
+ _Name=Nimbus
+ _Comment=Sun Microsystems, Inc. default theme
+-Encoding=UTF-8
+
+ [X-GNOME-Metatheme]
+ GtkTheme=nimbus
+--- a/light-index.theme.in
++++ b/light-index.theme.in
+@@ -2,7 +2,6 @@
+ Type=X-GNOME-Metatheme
+ _Name=Light Nimbus
+ _Comment=Sun Microsystems, Inc. alternative theme
+-Encoding=UTF-8
+
+ [X-GNOME-Metatheme]
+ GtkTheme=light-nimbus
diff --git a/x11-themes/nimbus/nimbus-0.1.7-r1.ebuild b/x11-themes/nimbus/nimbus-0.1.7-r1.ebuild
index 44cf2230a166..6ee30e99e329 100644
--- a/x11-themes/nimbus/nimbus-0.1.7-r1.ebuild
+++ b/x11-themes/nimbus/nimbus-0.1.7-r1.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
+
AUTOTOOLS_AUTO_DEPEND=no
-inherit autotools gnome2-utils
+inherit autotools xdg
DESCRIPTION="The default OpenSolaris theme (GTK+ 2.x engine, icon- and metacity theme)"
HOMEPAGE="http://dlc.sun.com/osol/jds/downloads/extras/nimbus/"
@@ -14,47 +15,46 @@ SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
IUSE="gtk minimal"
-COMMON_DEPEND="gtk? ( x11-libs/gtk+:2 )"
-RDEPEND="${COMMON_DEPEND}
- !minimal? ( || ( x11-themes/adwaita-icon-theme x11-themes/tango-icon-theme ) )"
-DEPEND="${COMMON_DEPEND}
+DEPEND="gtk? ( x11-libs/gtk+:2 )"
+RDEPEND="
+ ${DEPEND}
+ !minimal? (
+ || (
+ x11-themes/adwaita-icon-theme
+ x11-themes/tango-icon-theme
+ )
+ )"
+BDEPEND="
dev-util/intltool
virtual/pkgconfig
- >=x11-misc/icon-naming-utils-0.8.90
- !gtk? ( ${AUTOTOOLS_DEPEND} )
- elibc_Interix? ( ${AUTOTOOLS_DEPEND} )"
-
-src_prepare() {
- # Tango is deprecated
- sed -i -e '/^Inherits/s:Tango:gnome,&:' icons/index.theme.in || die
+ x11-misc/icon-naming-utils
+ !gtk? ( ${AUTOTOOLS_DEPEND} )"
- # Encoding= key is obsolete
- sed -i -e '/^Encoding/d' *.theme.in || die
+PATCHES=( "${FILESDIR}"/${PN}-0.1.7-fix-themes.patch )
- use gtk || { sed -i \
- -e '/^gtk-engine/d' -e '/GTK2/d' -e '/^SUBDIRS/s:gtk-engine ::' \
- configure.in Makefile.am || die; }
+src_prepare() {
+ xdg_src_prepare
- local f=po/POTFILES.skip
- echo light-index.theme.in >> ${f}
- echo dark-index.theme.in >> ${f}
+ echo light-index.theme.in >> po/POTFILES.skip || die
+ echo dark-index.theme.in >> po/POTFILES.skip || die
- if [[ ${CHOST} == *-interix* ]] || ! use gtk; then
+ if ! use gtk; then
+ sed -e '/GTK2/d' \
+ -e '/^gtk-engine/d' \
+ -e '/^SUBDIRS/s:gtk-engine ::' \
+ -i configure.in Makefile.am || die
+ mv configure.{in,ac} || die
eautoreconf
fi
}
src_configure() {
- econf $(use gtk && echo --disable-static)
+ econf --disable-static
}
src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog
+ default
- use gtk && find "${ED}"/usr -name libnimbus.la -exec rm -f {} +
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}
-
-pkg_preinst() { gnome2_icon_savelist; }
-pkg_postinst() { gnome2_icon_cache_update; }
-pkg_postrm() { gnome2_icon_cache_update; }