summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2020-12-08 18:09:42 -0500
committerMatt Turner <mattst88@gentoo.org>2020-12-18 17:04:32 -0500
commit707b813d25500f37c741e0f9a0363f3a56f80ecd (patch)
treeb10c64aa65b1cb4128b374a33a256c2a36e6550f /x11-themes
parentgnome-base/librsvg: bump the C version to EAPI 7 (diff)
downloadgentoo-707b813d25500f37c741e0f9a0363f3a56f80ecd.tar.gz
gentoo-707b813d25500f37c741e0f9a0363f3a56f80ecd.tar.bz2
gentoo-707b813d25500f37c741e0f9a0363f3a56f80ecd.zip
x11-themes/adwaita-icon-theme: EAPI 7
This moves gtk+ and librsvg to BDEPEND so a natively executable gtk-encode-symbolic-svg program is available at build time. The warning about requiring a new librsvg was dropped since a higher version requirement is now enforced by dependencies. Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.32.0.ebuild14
-rw-r--r--x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1-r1.ebuild19
2 files changed, 12 insertions, 21 deletions
diff --git a/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.32.0.ebuild b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.32.0.ebuild
index 51f5ea054495..e6b170a05836 100644
--- a/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.32.0.ebuild
+++ b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.32.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
inherit gnome2
@@ -21,17 +21,15 @@ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd
# gtk+:3 is needed for build for the gtk-encode-symbolic-svg utility
# librsvg is needed for gtk-encode-symbolic-svg to be able to read the source SVG via its pixbuf loader and at runtime for rendering scalable icons shipped by the theme
-COMMON_DEPEND="
- >=x11-themes/hicolor-icon-theme-0.10
+DEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+RDEPEND="${DEPEND}
gnome-base/librsvg:2
"
-RDEPEND="${COMMON_DEPEND}
- !<x11-themes/gnome-themes-standard-3.14
-"
-DEPEND="${COMMON_DEPEND}
- x11-libs/gtk+:3
+BDEPEND="
+ gnome-base/librsvg:2
sys-devel/gettext
virtual/pkgconfig
+ x11-libs/gtk+:3
"
# This ebuild does not install any binaries
RESTRICT="binchecks strip"
diff --git a/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1-r1.ebuild b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1-r1.ebuild
index 42cbbedd2a10..ec449ae6fa1a 100644
--- a/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1-r1.ebuild
+++ b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
inherit gnome2
@@ -21,14 +21,15 @@ KEYWORDS="amd64 arm arm64 ppc64 x86 ~amd64-linux ~x86-linux"
# gtk+:3 is needed for build for the gtk-encode-symbolic-svg utility
# librsvg is needed for gtk-encode-symbolic-svg to be able to read the source SVG via its pixbuf loader and at runtime for rendering scalable icons shipped by the theme
-RDEPEND="
- >=x11-themes/hicolor-icon-theme-0.10
+DEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+RDEPEND="${DEPEND}
>=gnome-base/librsvg-2.48:2
"
-DEPEND="${RDEPEND}
- x11-libs/gtk+:3
+BDEPEND="
+ >=gnome-base/librsvg-2.48:2
sys-devel/gettext
virtual/pkgconfig
+ x11-libs/gtk+:3
"
# This ebuild does not install any binaries
RESTRICT="binchecks strip"
@@ -51,13 +52,5 @@ src_prepare() {
}
src_configure() {
- # less than 2.45 being a problem is just a guess, but we didn't carry anything between 2.40 and 2.48 in main tree
- if has_version '<gnome-base/librsvg-2.45:2'; then
- ewarn "You are building ${CATEGORY}/${PN} against an older"
- ewarn "gnome-base/librsvg, which will result in various broken symbolic icons until"
- ewarn "rebuild with newer librsvg, and misrendering of scalable icons at runtime"
- ewarn "until gnome-base/librsvg is upgraded!"
- fi
-
gnome2_src_configure GTK_UPDATE_ICON_CACHE=$(type -P true)
}