summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-16 18:46:53 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-16 18:51:01 -0400
commit72ad7b2a79e4be478a528b178ccdcaa2f52f0984 (patch)
tree0023549f90ab3de3290cc5903c7ee403a7dd74a7 /x11-themes
parentsys-kernel/gentoo-kernel-bin: Bump to 5.11.15 (diff)
downloadgentoo-72ad7b2a79e4be478a528b178ccdcaa2f52f0984.tar.gz
gentoo-72ad7b2a79e4be478a528b178ccdcaa2f52f0984.tar.bz2
gentoo-72ad7b2a79e4be478a528b178ccdcaa2f52f0984.zip
x11-themes/adwaita-icon-theme: Version bump to 40.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/adwaita-icon-theme/Manifest1
-rw-r--r--x11-themes/adwaita-icon-theme/adwaita-icon-theme-40.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-themes/adwaita-icon-theme/Manifest b/x11-themes/adwaita-icon-theme/Manifest
index 1a57bdccbaba..53b5a13a5c9f 100644
--- a/x11-themes/adwaita-icon-theme/Manifest
+++ b/x11-themes/adwaita-icon-theme/Manifest
@@ -1,3 +1,4 @@
DIST adwaita-icon-theme-3.32.0.tar.xz 18540012 BLAKE2B a82ca6758cdbf459ac617d3b3d834e4147c3a3c5e6ca7c705ed2d16e8cf0a1255f5ae999d7e930b9716585b8c498c220f1ab40fec929dde7679efd56f3b18a45 SHA512 9609732cd51c6794d4d86598818bb2a589b0f4b6b795e57f3507dad69b21ef1b2fc2e83e24e937428bbace32fcccf587a5771cbc02c5768206e704f0456a6d1d
DIST adwaita-icon-theme-3.38.0.tar.xz 17202144 BLAKE2B 88bde0758a40188cd55432d35edb92c3f1f62ce79a5b44b6271ea039841b22feadfea071899e71aaf449e3d077e6dcb65e01ecfbc62732c27036dca6cb72afb8 SHA512 710f034ef80476a4e9d60bcb7ba604e340ac561aafc67400b2cee2aac4696bfaab8a7d69a289116f884cce9bad1f8b3a3e0aff77588ecb9262e7bf250740af13
+DIST adwaita-icon-theme-40.0.tar.xz 18294376 BLAKE2B 7829db2d8e44a8c71372ebc427aed08125de61c12e313d3b8a4b8e1c7202a9b6e3b8e87e123a1498ef5f01360fa88436622f482add7aad6c9de6ae3256ca7682 SHA512 c9626bc4ea11f283c6e9396fe722414d3dde8609b6a952288f48185352841a88a229d837591351856ffcf840d6597b04ff4e78e58b3ebe22d44e3f509217455d
DIST tango-gentoo-v1.1.tar.gz 29322 BLAKE2B 83fa2bf37727e60851dd679054fe1b153ebfea58c9a9a40f891f7d68d3b047b02e8effa1d1b4e08d64500a2072ce7200f159c92a352da7124de27e1b05bb6027 SHA512 87d47ddab68361db6d99866c51705dcb3e198f8345a1096859acf2c6cca5099dd23c7fb30d124f52c4933ea38fd45fadffbbe6ecbdfa84f5b60938a4824f9045
diff --git a/x11-themes/adwaita-icon-theme/adwaita-icon-theme-40.0.ebuild b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-40.0.ebuild
new file mode 100644
index 000000000000..a801bc699898
--- /dev/null
+++ b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-40.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2
+
+DESCRIPTION="GNOME default icon theme"
+HOMEPAGE="https://git.gnome.org/browse/adwaita-icon-theme/"
+
+SRC_URI="${SRC_URI}
+ branding? ( https://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )
+"
+LICENSE="
+ || ( LGPL-3 CC-BY-SA-3.0 )
+ branding? ( CC-BY-SA-4.0 )
+"
+SLOT="0"
+IUSE="branding"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+# gtk+:3 is needed for build for the gtk-encode-symbolic-svg utility
+# librsvg is needed for gtk-encode-symbolic-svg to be able to read the source SVG via its pixbuf loader and at runtime for rendering scalable icons shipped by the theme
+DEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+RDEPEND="${DEPEND}
+ >=gnome-base/librsvg-2.48:2
+"
+BDEPEND="
+ >=gnome-base/librsvg-2.48:2
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-libs/gtk+:3
+"
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ if use branding; then
+ for i in 16 22 24 32 48; do
+ cp "${WORKDIR}"/tango-gentoo-v1.1/${i}x${i}/gentoo.png \
+ "${S}"/Adwaita/${i}x${i}/places/start-here.png \
+ || die "Copying gentoo logos failed"
+ done
+ fi
+
+ # Install cursors in the right place used in Gentoo
+ sed -e 's:^\(cursordir.*\)icons\(.*\):\1cursors/xorg-x11\2:' \
+ -i "${S}"/Makefile.am \
+ -i "${S}"/Makefile.in || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure GTK_UPDATE_ICON_CACHE=$(type -P true)
+}