summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-05 18:03:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-05 18:08:45 +0200
commit88894187c72800cb4491cf3abf1e532197d45f75 (patch)
treea199a39bc30544f580203d0ef24e057c5ece0b9a /x11-themes
parentsys-cluster/glusterfs: drop vulnerable wrt #670088 (diff)
downloadgentoo-88894187c72800cb4491cf3abf1e532197d45f75.tar.gz
gentoo-88894187c72800cb4491cf3abf1e532197d45f75.tar.bz2
gentoo-88894187c72800cb4491cf3abf1e532197d45f75.zip
x11-themes/qtcurve: Fix build with GCC-9
Closes: https://bugs.gentoo.org/685794 Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/qtcurve/files/qtcurve-1.9.0-gcc9.patch26
-rw-r--r--x11-themes/qtcurve/qtcurve-1.9.0.ebuild3
2 files changed, 28 insertions, 1 deletions
diff --git a/x11-themes/qtcurve/files/qtcurve-1.9.0-gcc9.patch b/x11-themes/qtcurve/files/qtcurve-1.9.0-gcc9.patch
new file mode 100644
index 000000000000..56bf30b4562e
--- /dev/null
+++ b/x11-themes/qtcurve/files/qtcurve-1.9.0-gcc9.patch
@@ -0,0 +1,26 @@
+From ee2228ea2f18ac5da9b434ee6089381df815aa94 Mon Sep 17 00:00:00 2001
+From: Yichao Yu <yyc1992@gmail.com>
+Date: Wed, 5 Jun 2019 09:03:40 -0400
+Subject: [utils/gtkprops] Remove unnecessary constexpr, this is not allowed in
+ C++14
+
+BUG: 408286
+---
+ lib/utils/gtkprops.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/utils/gtkprops.h b/lib/utils/gtkprops.h
+index abc0675..e248255 100644
+--- a/lib/utils/gtkprops.h
++++ b/lib/utils/gtkprops.h
+@@ -74,7 +74,7 @@ class GtkWidgetProps {
+ };
+ #define DEF_WIDGET_SIG_CONN_PROPS(name) \
+ struct _SigConn_##name##_ObjGetter { \
+- constexpr inline GObject* \
++ inline GObject* \
+ operator()(SigConn<_SigConn_##name##_ObjGetter> *p) const \
+ { \
+ return (GObject*)qtcContainerOf(p, Props, name)->m_w; \
+--
+cgit v1.1
diff --git a/x11-themes/qtcurve/qtcurve-1.9.0.ebuild b/x11-themes/qtcurve/qtcurve-1.9.0.ebuild
index 85ce451395d6..428c60441af9 100644
--- a/x11-themes/qtcurve/qtcurve-1.9.0.ebuild
+++ b/x11-themes/qtcurve/qtcurve-1.9.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -71,6 +71,7 @@ DOCS=( AUTHORS ChangeLog.md README.md TODO.md )
PATCHES=(
"${FILESDIR}/${PN}-1.9.0-build_testing.patch"
"${FILESDIR}/${PN}-1.9.0-no-X-buildfix.patch"
+ "${FILESDIR}/${PN}-1.9.0-gcc9.patch"
)
src_configure() {