summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-12-15 23:00:42 +0100
committerMarek Szuba <marecki@gentoo.org>2020-12-15 23:10:50 +0100
commit9b182d1f3734c2fbf2398510653f202f352faa63 (patch)
treeadad159278adf1c91489496aa6f8aff44d6d710f /x11-themes
parentdev-python/isort: keyworded 5.6.3 for sparc, bug #747850 (diff)
downloadgentoo-9b182d1f3734c2fbf2398510653f202f352faa63.tar.gz
gentoo-9b182d1f3734c2fbf2398510653f202f352faa63.tar.bz2
gentoo-9b182d1f3734c2fbf2398510653f202f352faa63.zip
x11-themes/gtk-engines: migrate to lua-single.eclass
Builds, tests and installs fine even when built against lua5-4 so support all PUC Lua versions currently in the tree. Warning - as the ebuild stands now, USE=lua IS QUIETLY IGNORED for non-native ABIs. The dependencies are ready for enabling it there as well but since the pkgconfig wrapper lua-single.eclass sets up is not multilib-compatible, it is necessary to patch upstream build scripts so that they look for the pkgconfig module "${ELUA}" rather than just "lua" - and for some reason running eautoreconf following the patching of configure.ac resulted in corrupted test Makefiles. Pushing it as-is in case the maintainers have got some idea on how to make this work, if not will probably end up patching configure directly. Bug: https://bugs.gentoo.org/752888 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-engines/gtk-engines-2.20.2-r100.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines/gtk-engines-2.20.2-r100.ebuild b/x11-themes/gtk-engines/gtk-engines-2.20.2-r100.ebuild
new file mode 100644
index 000000000000..597dc742bc9a
--- /dev/null
+++ b/x11-themes/gtk-engines/gtk-engines-2.20.2-r100.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GNOME2_LA_PUNT="yes"
+GNOME_TARBALL_SUFFIX="bz2"
+LUA_COMPAT=( lua5-{1..4} )
+
+inherit autotools gnome2 lua-single multilib-minimal
+
+DESCRIPTION="GTK+2 standard engines and themes"
+HOMEPAGE="https://www.gtk.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="accessibility lua"
+
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+
+# Lua dependency uses lua_gen_impl_dep() because LUA_REQ_USE doesn't seem
+# to play nicely with MULTILIB_USEDEP.
+RDEPEND="
+ >=x11-libs/gtk+-2.24.23:2[${MULTILIB_USEDEP}]
+ lua? ( $(lua_gen_impl_dep "${MULTILIB_USEDEP}") )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-util/intltool-0.31
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-glib.h.patch
+ "${FILESDIR}"/${P}-java-look.patch
+ "${FILESDIR}"/${P}-auto-mnemonics.patch
+ "${FILESDIR}"/${P}-change-bullet.patch
+ "${FILESDIR}"/${P}-tooltips.patch
+ "${FILESDIR}"/${P}-window-dragging.patch
+)
+
+src_prepare() {
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ local confopts=(
+ --enable-animation
+ )
+ # TODO: fix system-lua detection so that it works for non-native ABIs,
+ # native builds rely on the pkgconfig wrapper set up by lua-single.eclass
+ # but that wrapper is not multilib-compatible.
+ if multilib_is_native_abi; then
+ confopts+=(
+ $(use_enable lua)
+ $(use_with lua system-lua)
+ )
+ else
+ confopts+=(
+ --disable-lua
+ )
+ fi
+ ECONF_SOURCE=${S} gnome2_src_configure "${confopts[@]}"
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+}