summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-05-22 15:08:11 +0200
committerPacho Ramos <pacho@gentoo.org>2023-05-22 15:08:11 +0200
commitb7621607097382288e50a8df40d0be9787a676eb (patch)
treeb504cb734ca7b82bf81c014cf24aea72521f5d79 /x11-themes
parentkde-plasma/xembed-sni-proxy: drop 5.27.4.1 (diff)
downloadgentoo-b7621607097382288e50a8df40d0be9787a676eb.tar.gz
gentoo-b7621607097382288e50a8df40d0be9787a676eb.tar.bz2
gentoo-b7621607097382288e50a8df40d0be9787a676eb.zip
x11-themes/QGnomePlatform: qqc2-desktop-style is needed
Otherwise people gets a warning on every app as it can cause issues like some apps rendering wrong or completely black. Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/QGnomePlatform/QGnomePlatform-0.9.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-themes/QGnomePlatform/QGnomePlatform-0.9.1-r1.ebuild b/x11-themes/QGnomePlatform/QGnomePlatform-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..97098a1caae6
--- /dev/null
+++ b/x11-themes/QGnomePlatform/QGnomePlatform-0.9.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="A Qt Platform Theme aimed to accommodate GNOME settings"
+HOMEPAGE="https://github.com/FedoraQt/QGnomePlatform"
+SRC_URI="https://github.com/FedoraQt/QGnomePlatform/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="wayland"
+
+RDEPEND="
+ dev-qt/qtdbus:5=
+ >=dev-qt/qtquickcontrols2-5.15.2:5=
+ >=dev-qt/qtwidgets-5.15.2:5=
+ kde-frameworks/qqc2-desktop-style:5=
+ wayland? ( dev-qt/qtwayland:5= )
+ gnome-base/gsettings-desktop-schemas
+ sys-apps/xdg-desktop-portal
+ x11-libs/gtk+:3
+ >=x11-themes/adwaita-qt-1.4.2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT6=false
+ -DDISABLE_DECORATION_SUPPORT="$(usex wayland false true)"
+ )
+ cmake_src_configure
+}