summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2016-09-10 23:09:47 +0200
committerTobias Klausmann <klausman@gentoo.org>2016-09-10 23:09:47 +0200
commitcfc3a87c6e403fde395e87d9b6aaa9bb2acb7ddb (patch)
tree12f6cfb9bc9a8d09492f116b6e2877053ef44aee /x11-themes
parentapp-text/sigil: version bump for bug 592738 (diff)
downloadgentoo-cfc3a87c6e403fde395e87d9b6aaa9bb2acb7ddb.tar.gz
gentoo-cfc3a87c6e403fde395e87d9b6aaa9bb2acb7ddb.tar.bz2
gentoo-cfc3a87c6e403fde395e87d9b6aaa9bb2acb7ddb.zip
x11-themes/qtcurve: fix usage of isnan() for bug 431848
Gentoo-Bug: 431848
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/qtcurve/files/qtcurve-1.8.18-std_isnan.patch22
-rw-r--r--x11-themes/qtcurve/qtcurve-1.8.18-r1.ebuild1
2 files changed, 23 insertions, 0 deletions
diff --git a/x11-themes/qtcurve/files/qtcurve-1.8.18-std_isnan.patch b/x11-themes/qtcurve/files/qtcurve-1.8.18-std_isnan.patch
new file mode 100644
index 000000000000..ae78995d46fb
--- /dev/null
+++ b/x11-themes/qtcurve/files/qtcurve-1.8.18-std_isnan.patch
@@ -0,0 +1,22 @@
+Index: qtcurve-1.8.18/lib/utils/color.h
+===================================================================
+--- qtcurve-1.8.18.orig/lib/utils/color.h
++++ qtcurve-1.8.18/lib/utils/color.h
+@@ -250,7 +250,7 @@ qtcColorTint(const QColor *base, const Q
+ return *base;
+ } else if (amount >= 1.0) {
+ return *col;
+- } else if (isnan(amount)) {
++ } else if (std::isnan(amount)) {
+ return *base;
+ }
+ const QtcColor qtc_base = {base->redF(), base->greenF(), base->blueF()};
+@@ -267,7 +267,7 @@ qtcColorMix(const QColor *c1, const QCol
+ return *c1;
+ } else if (bias >= 1.0) {
+ return *c2;
+- } else if (isnan(bias)) {
++ } else if (std::isnan(bias)) {
+ return *c1;
+ }
+ const QtcColor qtc_c1 = {c1->redF(), c1->greenF(), c1->blueF()};
diff --git a/x11-themes/qtcurve/qtcurve-1.8.18-r1.ebuild b/x11-themes/qtcurve/qtcurve-1.8.18-r1.ebuild
index eaa3aced377a..335092fbfcb3 100644
--- a/x11-themes/qtcurve/qtcurve-1.8.18-r1.ebuild
+++ b/x11-themes/qtcurve/qtcurve-1.8.18-r1.ebuild
@@ -55,6 +55,7 @@ PATCHES=(
"${DISTDIR}/${P}-dont_use_c++11.patch"
"${FILESDIR}/${P}-remove_qt_filedialog_api.patch"
"${FILESDIR}/${P}-gtk2_segfault.patch"
+ "${FILESDIR}/${P}-std_isnan.patch"
)
pkg_setup() {