summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-01-30 22:18:36 +0000
committerJames Le Cuirot <chewi@gentoo.org>2021-01-30 22:18:36 +0000
commite6a75d84e95663f09e43e2e249d462883880c2b1 (patch)
tree4a25c0af9eb395986501254407fc20e3be15a237 /x11-themes
parentdev-cpp/argparse: update DESCRIPTION (diff)
downloadgentoo-e6a75d84e95663f09e43e2e249d462883880c2b1.tar.gz
gentoo-e6a75d84e95663f09e43e2e249d462883880c2b1.tar.bz2
gentoo-e6a75d84e95663f09e43e2e249d462883880c2b1.zip
x11-themes/arc-theme: Version bump to 20210127, switch to Meson
Package-Manager: Portage-3.0.14, Repoman-3.0.1 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/arc-theme/Manifest2
-rw-r--r--x11-themes/arc-theme/arc-theme-20210127.ebuild110
-rw-r--r--x11-themes/arc-theme/files/meson-inkscape.patch91
-rw-r--r--x11-themes/arc-theme/files/pre-rendered.ini3
4 files changed, 206 insertions, 0 deletions
diff --git a/x11-themes/arc-theme/Manifest b/x11-themes/arc-theme/Manifest
index 6d006ca8b0ba..129141c7d154 100644
--- a/x11-themes/arc-theme/Manifest
+++ b/x11-themes/arc-theme/Manifest
@@ -1,2 +1,4 @@
DIST arc-theme-20201013-pngs.tar.xz 85204 BLAKE2B fb1ef7e0d9618238cf6057777d1494d6247b237d060c4c6772aa5a7ce740218f45f0ee6b2328bc486b8b29d2741c4c44dadcb8db5abf4e333ce519c7db961f9c SHA512 d7d28fe99ac7fce7360905eea0ed1a2cac77612dc7dde05240bbb2cf8e7cc0956f63c35426c1dae34d8adb20553758f595e442e955a202e9c73af5b61ca30a86
DIST arc-theme-20201013.tar.xz 241636 BLAKE2B 6f825b290c0f2cf1e67d72d9dbca0f23c83e7fc2ea89bc7b69013fb38bb7959205caad1b357a5cb1c4196e4b4460f13223515124c2012aa363a17765e89f992d SHA512 c1c70c80935af2b1f3c7c9bf79ee72d5fba907fd03caadecf96d6fd796bf70d325bbb16dbe93f95d9a63eff748c7d90bcb0bf837e446e5c2770cfdccb131f45c
+DIST arc-theme-20210127-pngs.tar.xz 159392 BLAKE2B 2a355e85766f44c21a4a85cacd184cb28ddb4ba19e7dff7cae70114c12422ed5d46a3930d780a6e2dd458684a944f5cbd17a769a0d3e331f94007b9fc9943238 SHA512 b0de3065e81979f2aa6b7f31edc1aad6dd6998776da2a1ba3b1030f6d8c552c9f1702e0bca0585e625e868541b0444b7a0d75631dfbeef517bdb9925e19e6159
+DIST arc-theme-20210127.tar.xz 256364 BLAKE2B 4e85d2ca801977588273715a94b91e199e3f16d304090789748e22b55c1339386a84938da1b1c143004655d8573678a51ff3b27e9ac3a2027de93625b0f39ada SHA512 bb0554c96cf6c3c3891698d973e7d719931fc316ea6cd910f69d21440110690aeef0e734b5f940ad1c81bdff238477b6353de4ae074cd54fbed09c680377d594
diff --git a/x11-themes/arc-theme/arc-theme-20210127.ebuild b/x11-themes/arc-theme/arc-theme-20210127.ebuild
new file mode 100644
index 000000000000..e7a1d5c3bff4
--- /dev/null
+++ b/x11-themes/arc-theme/arc-theme-20210127.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# USE="-* gtk2 gtk3 xfce" ebuild ${P}.ebuild clean compile
+# cd $(portageq envvar PORTAGE_TMPDIR)/portage/x11-themes/${P}/work
+# find ${P}-build/ -name "*.png" | xargs tar Jcvf /usr/portage/distfiles/${P}-pngs.tar.xz --owner=root --group=root
+
+inherit meson toolchain-funcs
+
+DESCRIPTION="A flat theme with transparent elements for GTK+3, GTK+2 and GNOME Shell"
+HOMEPAGE="https://github.com/jnsh/arc-theme"
+SRC_URI="https://github.com/jnsh/${PN}/releases/download/${PV}/arc-theme-${PV}.tar.xz
+ pre-rendered? ( https://dev.gentoo.org/~chewi/distfiles/${P}-pngs.tar.xz )"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="cinnamon gnome-shell +gtk2 +gtk3 mate +pre-rendered xfce"
+
+SASSC_DEPEND="
+ dev-lang/sassc
+"
+
+SVG_DEPEND="
+ !pre-rendered? (
+ media-gfx/inkscape
+ media-gfx/optipng
+ )
+"
+
+# Supports various GTK+3, GNOME Shell, and Cinnamon versions and uses
+# pkg-config to determine which set of files to build. Updates will
+# therefore break existing installs but there's no way around this. At
+# least GTK+3 is unlikely to see a release beyond 3.24.
+BDEPEND="
+ >=dev-util/meson-0.56.0
+ cinnamon? (
+ ${SASSC_DEPEND}
+ gnome-extra/cinnamon
+ )
+ gnome-shell? (
+ ${SASSC_DEPEND}
+ >=gnome-base/gnome-shell-3.18
+ )
+ gtk2? (
+ ${SVG_DEPEND}
+ )
+ gtk3? (
+ ${SASSC_DEPEND}
+ ${SVG_DEPEND}
+ virtual/pkgconfig
+ =x11-libs/gtk+-3.24*:3
+ )
+ xfce? (
+ ${SVG_DEPEND}
+ )
+"
+
+# gnome-themes-standard is only needed by GTK+2 for the Adwaita
+# engine. This engine is built into GTK+3.
+RDEPEND="
+ gtk2? (
+ x11-themes/gnome-themes-standard
+ x11-themes/gtk-engines-murrine
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/meson-inkscape.patch
+)
+
+src_configure() {
+ local themes=$(
+ printf "%s," \
+ $(usev cinnamon) \
+ $(usev gnome-shell) \
+ $(usev gtk2) \
+ $(usev gtk3) \
+ $(usex mate metacity "") \
+ $(usex xfce xfwm "")
+ )
+
+ local emesonargs=(
+ -Dthemes="${themes%,}"
+ -Dgtk3_version=3.24
+ )
+
+ if use pre-rendered; then
+ emesonargs+=(
+ $(if tc-is-cross-compiler; then
+ echo --cross-file
+ else
+ echo --native-file
+ fi)
+ "${FILESDIR}"/pre-rendered.ini
+ )
+ fi
+
+ meson_src_configure
+}
+
+src_compile() {
+ # fontconfig issue?
+ # https://bugs.gentoo.org/666418#c28
+ use pre-rendered ||
+ addpredict "${BROOT}"/usr/share/inkscape/fonts/.uuid.TMP-XXXXXX
+
+ meson_src_compile
+}
diff --git a/x11-themes/arc-theme/files/meson-inkscape.patch b/x11-themes/arc-theme/files/meson-inkscape.patch
new file mode 100644
index 000000000000..dfec810aa53d
--- /dev/null
+++ b/x11-themes/arc-theme/files/meson-inkscape.patch
@@ -0,0 +1,91 @@
+From 6c2e91fb79177f64eae875e1091d35ad94a74f5a Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Thu, 28 Jan 2021 23:14:22 +0000
+Subject: [PATCH] build: Fix building with Inkscape 1.0
+
+This wasn't matching the >1.0.0 version check.
+---
+ common/gtk-2.0/dark/meson.build | 2 +-
+ common/gtk-2.0/light/meson.build | 2 +-
+ common/gtk-3.0/meson.build | 4 ++--
+ common/xfwm4/dark/meson.build | 2 +-
+ common/xfwm4/light/meson.build | 2 +-
+ 5 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/common/gtk-2.0/dark/meson.build b/common/gtk-2.0/dark/meson.build
+index 869beda9..c13608a8 100644
+--- a/common/gtk-2.0/dark/meson.build
++++ b/common/gtk-2.0/dark/meson.build
+@@ -8,7 +8,7 @@ foreach asset : gtk2_asset_names
+ command : [
+ inkscape,
+ '--export-id-only',
+- inkscape_ver.version_compare('>1.0.0') ? '--export-filename=@OUTPUT@' : '--export-png=@OUTPUT@',
++ inkscape_ver.version_compare('>=1.0') ? '--export-filename=@OUTPUT@' : '--export-png=@OUTPUT@',
+ '--export-id=' + asset,
+ '--export-dpi=96',
+ '@INPUT@'
+diff --git a/common/gtk-2.0/light/meson.build b/common/gtk-2.0/light/meson.build
+index 3df389a0..4dd32c63 100644
+--- a/common/gtk-2.0/light/meson.build
++++ b/common/gtk-2.0/light/meson.build
+@@ -8,7 +8,7 @@ foreach asset : gtk2_asset_names
+ command : [
+ inkscape,
+ '--export-id-only',
+- inkscape_ver.version_compare('>1.0.0') ? '--export-filename=@OUTPUT@' : '--export-png=@OUTPUT@',
++ inkscape_ver.version_compare('>=1.0') ? '--export-filename=@OUTPUT@' : '--export-png=@OUTPUT@',
+ '--export-id=' + asset,
+ '--export-dpi=96',
+ '@INPUT@'
+diff --git a/common/gtk-3.0/meson.build b/common/gtk-3.0/meson.build
+index fcb2e074..085bb739 100644
+--- a/common/gtk-3.0/meson.build
++++ b/common/gtk-3.0/meson.build
+@@ -50,7 +50,7 @@ foreach asset : gtk3_asset_names
+ command : [
+ inkscape,
+ '--export-id-only',
+- inkscape_ver.version_compare('>1.0.0') ? '--export-filename=@OUTPUT@' : '--export-png=@OUTPUT@',
++ inkscape_ver.version_compare('>=1.0') ? '--export-filename=@OUTPUT@' : '--export-png=@OUTPUT@',
+ '--export-id=' + asset,
+ '--export-dpi=96',
+ '@INPUT@'
+@@ -65,7 +65,7 @@ foreach asset : gtk3_asset_names
+ command : [
+ inkscape,
+ '--export-id-only',
+- inkscape_ver.version_compare('>1.0.0') ? '--export-filename=@OUTPUT@' : '--export-png=@OUTPUT@',
++ inkscape_ver.version_compare('>=1.0') ? '--export-filename=@OUTPUT@' : '--export-png=@OUTPUT@',
+ '--export-id=' + asset,
+ '--export-dpi=192',
+ '@INPUT@'
+diff --git a/common/xfwm4/dark/meson.build b/common/xfwm4/dark/meson.build
+index a2820df2..9bb7d46b 100644
+--- a/common/xfwm4/dark/meson.build
++++ b/common/xfwm4/dark/meson.build
+@@ -8,7 +8,7 @@ foreach asset : xfwm_asset_names
+ command : [
+ inkscape,
+ '--export-id-only',
+- inkscape_ver.version_compare('>1.0.0') ? '--export-filename=@OUTPUT@' : '--export-png=@OUTPUT@',
++ inkscape_ver.version_compare('>=1.0') ? '--export-filename=@OUTPUT@' : '--export-png=@OUTPUT@',
+ '--export-id=' + asset,
+ '--export-dpi=96',
+ '@INPUT@'
+diff --git a/common/xfwm4/light/meson.build b/common/xfwm4/light/meson.build
+index c65b891b..6ee79fc4 100644
+--- a/common/xfwm4/light/meson.build
++++ b/common/xfwm4/light/meson.build
+@@ -8,7 +8,7 @@ foreach asset : xfwm_asset_names
+ command : [
+ inkscape,
+ '--export-id-only',
+- inkscape_ver.version_compare('>1.0.0') ? '--export-filename=@OUTPUT@' : '--export-png=@OUTPUT@',
++ inkscape_ver.version_compare('>=1.0') ? '--export-filename=@OUTPUT@' : '--export-png=@OUTPUT@',
+ '--export-id=' + asset,
+ '--export-dpi=96',
+ '@INPUT@'
+--
+2.26.2
+
diff --git a/x11-themes/arc-theme/files/pre-rendered.ini b/x11-themes/arc-theme/files/pre-rendered.ini
new file mode 100644
index 000000000000..cf3b5771c2df
--- /dev/null
+++ b/x11-themes/arc-theme/files/pre-rendered.ini
@@ -0,0 +1,3 @@
+[binaries]
+inkscape = 'true'
+optipng = 'true'