summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-07-25 08:34:13 +0200
committerJeroen Roovers <jer@gentoo.org>2019-07-25 08:35:24 +0200
commit88efc473af2b86a25ed0ca2752f2e2eaa2a959d4 (patch)
tree8f65c318c6d9eeb4c0badcf2477a971956f4b7ca /x11-wm/ctwm/ctwm-4.0.3.ebuild
parentsci-mathematics/alt-ergo: Fix dependency (diff)
downloadgentoo-88efc473af2b86a25ed0ca2752f2e2eaa2a959d4.tar.gz
gentoo-88efc473af2b86a25ed0ca2752f2e2eaa2a959d4.tar.bz2
gentoo-88efc473af2b86a25ed0ca2752f2e2eaa2a959d4.zip
x11-wm/ctwm: Version 4.0.3
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Fixes: https://bugs.gentoo.org/690592 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-wm/ctwm/ctwm-4.0.3.ebuild')
-rw-r--r--x11-wm/ctwm/ctwm-4.0.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-wm/ctwm/ctwm-4.0.3.ebuild b/x11-wm/ctwm/ctwm-4.0.3.ebuild
new file mode 100644
index 000000000000..63fd567ef40a
--- /dev/null
+++ b/x11-wm/ctwm/ctwm-4.0.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake-utils
+
+DESCRIPTION="A clean, light window manager"
+HOMEPAGE="https://ctwm.org/"
+SRC_URI="${HOMEPAGE}dist/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ app-text/rman
+ virtual/jpeg
+ x11-base/xorg-proto
+"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # implicit 'isspace'
+ sed -i parse.c -e "/<stdio.h>/ a#include <ctype.h>" || die
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DNOMANCOMPRESS=yes
+ -DDOCDIR=/usr/share/doc/${PF}
+ )
+
+ cmake-utils_src_configure
+}