summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-02-05 16:35:31 +0100
committerJeroen Roovers <jer@gentoo.org>2019-02-05 16:35:46 +0100
commita5f1156d2eaac56b8a9fc2216e6a7fe8e0f31d40 (patch)
tree207b1e9256fd69574e78e4ea1175e8a1b579cd86 /x11-wm/dwm/dwm-6.2.ebuild
parentx11-misc/dmenu: Version 4.9 (diff)
downloadgentoo-a5f1156d2eaac56b8a9fc2216e6a7fe8e0f31d40.tar.gz
gentoo-a5f1156d2eaac56b8a9fc2216e6a7fe8e0f31d40.tar.bz2
gentoo-a5f1156d2eaac56b8a9fc2216e6a7fe8e0f31d40.zip
x11-wm/dwm: Version 6.2
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-wm/dwm/dwm-6.2.ebuild')
-rw-r--r--x11-wm/dwm/dwm-6.2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/x11-wm/dwm/dwm-6.2.ebuild b/x11-wm/dwm/dwm-6.2.ebuild
new file mode 100644
index 000000000000..0344b44e7166
--- /dev/null
+++ b/x11-wm/dwm/dwm-6.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="a dynamic window manager for X11"
+HOMEPAGE="https://dwm.suckless.org/"
+SRC_URI="https://dl.suckless.org/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="xinerama"
+
+RDEPEND="
+ media-libs/fontconfig
+ x11-libs/libX11
+ x11-libs/libXft
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="
+ ${RDEPEND}
+ xinerama? ( x11-base/xorg-proto )
+"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s/ -Os / /" \
+ -e "/^\(LDFLAGS\|CFLAGS\|CPPFLAGS\)/{s| = | += |g;s|-s ||g}" \
+ config.mk || die
+
+ restore_config config.h
+}
+
+src_compile() {
+ if use xinerama; then
+ emake CC=$(tc-getCC) dwm
+ else
+ emake CC=$(tc-getCC) XINERAMAFLAGS="" XINERAMALIBS="" dwm
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/dwm-session2 dwm
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/dwm.desktop
+
+ dodoc README
+
+ save_config config.h
+}