summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-02-05 16:35:31 +0100
committerJeroen Roovers <jer@gentoo.org>2019-02-05 16:35:46 +0100
commita5f1156d2eaac56b8a9fc2216e6a7fe8e0f31d40 (patch)
tree207b1e9256fd69574e78e4ea1175e8a1b579cd86 /x11-wm/dwm/dwm-9999.ebuild
parentx11-misc/dmenu: Version 4.9 (diff)
downloadgentoo-a5f1156d2eaac56b8a9fc2216e6a7fe8e0f31d40.tar.gz
gentoo-a5f1156d2eaac56b8a9fc2216e6a7fe8e0f31d40.tar.bz2
gentoo-a5f1156d2eaac56b8a9fc2216e6a7fe8e0f31d40.zip
x11-wm/dwm: Version 6.2
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-wm/dwm/dwm-9999.ebuild')
-rw-r--r--x11-wm/dwm/dwm-9999.ebuild18
1 files changed, 4 insertions, 14 deletions
diff --git a/x11-wm/dwm/dwm-9999.ebuild b/x11-wm/dwm/dwm-9999.ebuild
index 27c5d18fe7ae..900dc238896c 100644
--- a/x11-wm/dwm/dwm-9999.ebuild
+++ b/x11-wm/dwm/dwm-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit git-r3 toolchain-funcs
DESCRIPTION="a dynamic window manager for X11"
@@ -28,19 +28,9 @@ src_prepare() {
default
sed -i \
- -e "s/CFLAGS = -std=c99 -pedantic -Wall -Os/CFLAGS += -std=c99 -pedantic -Wall/" \
- -e "/^LDFLAGS/{s|=|+=|g;s|-s ||g}" \
- -e "s/#XINERAMALIBS =/XINERAMALIBS ?=/" \
- -e "s/#XINERAMAFLAGS =/XINERAMAFLAGS ?=/" \
- -e "s@/usr/X11R6/include@${EPREFIX}/usr/include/X11@" \
- -e "s@/usr/X11R6/lib@${EPREFIX}/usr/lib@" \
- -e "s@-I/usr/include@@" -e "s@-L/usr/lib@@" \
- -e "s/\/freetype2/\ -I\/usr\/include\/freetype2/" \
+ -e "s/ -Os / /" \
+ -e "/^\(LDFLAGS\|CFLAGS\|CPPFLAGS\)/{s| = | += |g;s|-s ||g}" \
config.mk || die
- sed -i \
- -e '/@echo CC/d' \
- -e 's|@${CC}|$(CC)|g' \
- Makefile || die
}
src_compile() {