summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 08:10:10 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:10:38 +0100
commit2191c4ec4e9accc5d149d72c0fa15fad43415137 (patch)
tree4ae7cfe85fcb59357b720dee575b138ccfc0c230 /x11-wm/echinus
parentx11-wm/cwm: tidy up patches (diff)
downloadgentoo-2191c4ec4e9accc5d149d72c0fa15fad43415137.tar.gz
gentoo-2191c4ec4e9accc5d149d72c0fa15fad43415137.tar.bz2
gentoo-2191c4ec4e9accc5d149d72c0fa15fad43415137.zip
x11-wm/echinus: respect PKG_CONFIG
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-wm/echinus')
-rw-r--r--x11-wm/echinus/echinus-0.4.9.ebuild5
-rw-r--r--x11-wm/echinus/files/echinus-0.4.9-gentoo.diff8
2 files changed, 7 insertions, 6 deletions
diff --git a/x11-wm/echinus/echinus-0.4.9.ebuild b/x11-wm/echinus/echinus-0.4.9.ebuild
index 214543732284..551dcde04be1 100644
--- a/x11-wm/echinus/echinus-0.4.9.ebuild
+++ b/x11-wm/echinus/echinus-0.4.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -27,7 +27,7 @@ src_configure() {
use xrandr && export MULTIHEAD=1
sed -i -e "s|/usr/lib|/usr/$(get_libdir)|g" config.mk || die
- tc-export CC
+ tc-export CC PKG_CONFIG
}
src_install() {
@@ -50,6 +50,7 @@ pkg_postinst() {
elog "to launch dmenu_run. Check echinus documentation for details."
elog ""
fi
+
elog "A standard config file with its pixmaps has been installed to:"
elog "${EROOT}/usr/share/${PN}/examples"
elog "Copy this folder to ~/.${PN}/ and modify the echinusrc as you wish."
diff --git a/x11-wm/echinus/files/echinus-0.4.9-gentoo.diff b/x11-wm/echinus/files/echinus-0.4.9-gentoo.diff
index 2bada877b17a..5c013c7166ff 100644
--- a/x11-wm/echinus/files/echinus-0.4.9-gentoo.diff
+++ b/x11-wm/echinus/files/echinus-0.4.9-gentoo.diff
@@ -21,8 +21,8 @@
-LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 `pkg-config --libs xft`
-
-DEFS = -DVERSION=\"${VERSION}\" -DSYSCONFPATH=\"${CONF}\"
-+CFLAGS += -I. -I/usr/include `pkg-config --cflags x11 xft`
-+LIBS += -L/usr/lib -lc `pkg-config --libs x11 xft`
++CFLAGS += -I. -I/usr/include `${PKG_CONFIG} --cflags x11 xft`
++LIBS += -L/usr/lib -lc `${PKG_CONFIG} --libs x11 xft`
+CPPFLAGS += -DVERSION=\"${VERSION}\" -DSYSCONFPATH=\"${CONF}\"
# flags
@@ -42,8 +42,8 @@
-
+ifdef MULTIHEAD
+CPPFLAGS += -DXRANDR=1
-+LIBS += `pkg-config --libs xrandr`
-+CCFLAGS += `pkg-config --libs xrandr`
++LIBS += `${PKG_CONFIG} --libs xrandr`
++CCFLAGS += `${PKG_CONFIG} --libs xrandr`
+endif
# Solaris
#CFLAGS = -fast ${INCS} -DVERSION=\"${VERSION}\"