summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-08-08 11:31:51 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-08-08 11:32:07 +0200
commit41e19db18c1f4b6b438e7a288b2c199d95845f4a (patch)
treea815c30ad0ddd5db229eae0c2e16d7def3c4a99f /x11-wm/icewm
parentsys-apps/help2man: Bump to version 1.48.4 (diff)
downloadgentoo-41e19db18c1f4b6b438e7a288b2c199d95845f4a.tar.gz
gentoo-41e19db18c1f4b6b438e7a288b2c199d95845f4a.tar.bz2
gentoo-41e19db18c1f4b6b438e7a288b2c199d95845f4a.zip
x11-wm/icewm: Bump to version 2.7.0
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-wm/icewm')
-rw-r--r--x11-wm/icewm/Manifest1
-rw-r--r--x11-wm/icewm/icewm-2.7.0.ebuild153
2 files changed, 154 insertions, 0 deletions
diff --git a/x11-wm/icewm/Manifest b/x11-wm/icewm/Manifest
index 67f828dda5fb..945c4c0878d6 100644
--- a/x11-wm/icewm/Manifest
+++ b/x11-wm/icewm/Manifest
@@ -1,2 +1,3 @@
DIST icewm-2.5.0.tar.lz 1722504 BLAKE2B caf5d61559dd5bb25583bebeaca82e54049e2a97d8e5eeb93942908481f68614cfe55afd4041b5d60e58e732fef1694f67c5918a130bc55b252ebae67a51482a SHA512 1f59b4dbe90ca47031e5abf999cdb23a8e9ea956d5a76a0dde9b3489dec4530bf0ce72e10b337615d0bcadf04007b00a7db6f43082504bef65b109f9115d9f52
DIST icewm-2.6.0.tar.lz 1722772 BLAKE2B 4d7055b77d88d0731517b668f525161a97b571f68cf0b2944e9b364653cb022f0b29d664ccc9539d1807005ab8954aa3ce31244911c2fafaa673ef5afeb447f1 SHA512 fe491c8c59aa530d48a20134857c787eccfeda5bd9529e063d865bd3c5f243ef41fbecba40aa06e7fa8037af89839958095debebc5d9b1acc9b5670bd0e12eb6
+DIST icewm-2.7.0.tar.lz 1738471 BLAKE2B 407f5290329de99519b806db4bbc8895623d2930f37912db701170145579a1c2819b7ae2576b0aee146e8b006a12c78f7344224dd407ed7e8a1eba1cffc43ced SHA512 829673a3f7aa26fd7f74a9a8ab220548b6bb7724026517fa7ec1d5705fca2c0aa9339078d603242dbb2209c194a7a64aebcf55454aea5f8a20c4785e63e8cc3f
diff --git a/x11-wm/icewm/icewm-2.7.0.ebuild b/x11-wm/icewm/icewm-2.7.0.ebuild
new file mode 100644
index 000000000000..7b0d626e90a0
--- /dev/null
+++ b/x11-wm/icewm/icewm-2.7.0.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools unpacker
+
+DESCRIPTION="Ice Window Manager with Themes"
+HOMEPAGE="https://ice-wm.org/ https://github.com/ice-wm/icewm"
+LICENSE="GPL-2"
+SRC_URI="https://github.com/ice-wm/icewm/releases/download/${PV}/${P}.tar.lz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+alsa ao bidi debug +gdk-pixbuf imlib nls truetype uclibc xinerama"
+
+# Tests broken in all versions, patches welcome, bug #323907, #389533
+RESTRICT="test"
+
+REQUIRED_USE="|| ( alsa ao )"
+#?? ( gdk-pixbuf imlib )
+
+#fix for icewm preversion package names
+S="${WORKDIR}/${P/_}"
+
+# These are the core dependencies of icewm.
+# Look into configure.ac and search for PKG_CHECK_MODULES([CORE]
+CORE_DEPEND="
+ media-libs/fontconfig
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrender
+"
+
+RDEPEND="
+ ${CORE_DEPEND}
+ dev-libs/glib:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXft
+ x11-libs/libXpm
+ x11-libs/libXrandr
+ alsa? (
+ media-libs/alsa-lib
+ media-libs/libsndfile[alsa]
+ )
+ ao? (
+ media-libs/libao
+ media-libs/libsndfile
+ )
+ bidi? ( dev-libs/fribidi )
+ gdk-pixbuf? (
+ x11-libs/gdk-pixbuf-xlib
+ >=x11-libs/gdk-pixbuf-2.42.0:2
+ )
+ !gdk-pixbuf? (
+ imlib? (
+ gnome-base/librsvg:2
+ media-libs/imlib2
+ )
+ !imlib? (
+ media-libs/libpng:0=
+ virtual/jpeg
+ )
+ )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="
+ ${RDEPEND}
+ $(unpacker_src_uri_depends)
+ x11-base/xorg-proto
+ gdk-pixbuf? ( gnome-base/librsvg:2 )
+"
+
+BDEPEND="
+ app-text/asciidoc
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.19.8 )
+"
+
+pkg_pretend() {
+ if use gdk-pixbuf && use imlib ; then
+ einfo 'Confilcting USE flags have been enabled:'
+ einfo '"gdk-pixbuf" and "imlib" exclude each other!'
+ einfo 'Using "gdk-pixbuf".'
+ fi
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local icesound
+ if use alsa && use ao ; then
+ icesound="alsa,ao"
+ elif use alsa ; then
+ icesound="alsa"
+ elif use ao ; then
+ icesound="ao"
+ fi
+
+ local myconf=(
+ --enable-logevents
+ --enable-xrandr
+ --with-cfgdir="${EPREFIX}"/etc/icewm
+ --with-docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+ --with-icesound="${icesound}"
+ --with-libdir="${EPREFIX}"/usr/share/icewm
+ $(use_enable bidi fribidi)
+ $(use_enable debug)
+ $(use_enable debug logevents)
+ $(use_enable gdk-pixbuf)
+ $(use_enable imlib imlib2)
+ $(use_enable nls i18n)
+ $(use_enable nls)
+ $(use_enable xinerama)
+ )
+ if use truetype ; then
+ myconf+=(
+ --enable-shape
+ )
+ else
+ myconf+=(
+ --disable-xfreetype
+ --enable-corefonts
+ )
+ fi
+
+ econf "${myconf[@]}"
+
+ sed \
+ -e "s:/icewm-\$(VERSION)::" \
+ -e "s:ungif:gif:" \
+ -i src/Makefile || die
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog NEWS README.md TODO VERSION )
+
+ default
+
+ docinto html
+ dodoc doc/icewm.html
+ dodoc man/*.html
+
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}/icewm"
+}