summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-06-12 10:46:40 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-06-12 10:47:43 +0200
commit9ff86e45e20cb7a0b24555e34b999e5fe1a88430 (patch)
tree1961dbc4fed14aaba3aa03d536a29662acb25735 /x11-wm/icewm
parentnet-print/cups-filters: Removed old. (diff)
downloadgentoo-9ff86e45e20cb7a0b24555e34b999e5fe1a88430.tar.gz
gentoo-9ff86e45e20cb7a0b24555e34b999e5fe1a88430.tar.bz2
gentoo-9ff86e45e20cb7a0b24555e34b999e5fe1a88430.zip
x11-wm/icewm: Bump to version 1.5.5
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-wm/icewm')
-rw-r--r--x11-wm/icewm/Manifest1
-rw-r--r--x11-wm/icewm/icewm-1.5.5.ebuild119
2 files changed, 120 insertions, 0 deletions
diff --git a/x11-wm/icewm/Manifest b/x11-wm/icewm/Manifest
index d30bd8e1d18f..9c3a18bf06a0 100644
--- a/x11-wm/icewm/Manifest
+++ b/x11-wm/icewm/Manifest
@@ -1,3 +1,4 @@
DIST icewm-1.4.2.tar.gz 1709850 BLAKE2B 1a9dde495345f1601b3ae901b3e98554b60a9b9a8e94b7079f3c766971eb31bde5a3cd3972f5c96d86b5e02e413811df2a0689efc15a461bca39a70842f3df69 SHA512 c01661a7b07b4f42a32b20ecc9e45fb1e9c84c27d33105ec165e75aa9ac84129d55e992cac0d53fb10298bae28bc93ef07f68e874c1c2fccd9adecceb987a872
DIST icewm-1.5.3.tar.xz 1679384 BLAKE2B 6a855e6305083815173ed16f043ee6da3041b0b8ee537e5ac217dc6aca1d5a9b4303b7cf81ea4cd857fed55b64bd0842f6e2e7cacdf19d9c7abfb50df93a73d9 SHA512 3fb7bb3002687fc3105c61f062600015cf59173e054e3dc3dc1af4ec960991790bbb5b4ba842e9c67c8f73fb8189ae76772f3df58fd679884c85239e6d93a3cb
DIST icewm-1.5.4.tar.xz 1689668 BLAKE2B 19779e0b80da89ca5cdce3525a0f612b126e0e3d4c7569fe249ca78af7cc8ad16162361699d0a068f3394a2105f2afc1f7f644a02c7ad883469a9fa8c1fbf416 SHA512 7b5743872d328f937b49e2b79f7d6c0b8404326ef7e7a3b529c80138b36e8c2b30db79593125a8be76abe40282c779f79ca64b504f980ef2c87052448bdc076e
+DIST icewm-1.5.5.tar.xz 1707656 BLAKE2B 670ab4d1c1648faa24c848ddb04f3e353a3acd8e9a105837229d00ca344a61b3432d7b23b89dc054e220797cfd56d6504ad233d8793a3a5d95d9943c79017797 SHA512 5d75d33bf6e45ea0b46ace5173d825e9d1a12318cf7a5319b20ea704b019f6c09391f0f199b0fac678ba0f160d8236fc1cfee5d3b47d1895b7ba3721ff62a05e
diff --git a/x11-wm/icewm/icewm-1.5.5.ebuild b/x11-wm/icewm/icewm-1.5.5.ebuild
new file mode 100644
index 000000000000..1fb78abeecfd
--- /dev/null
+++ b/x11-wm/icewm/icewm-1.5.5.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Ice Window Manager with Themes"
+HOMEPAGE="https://ice-wm.org/ https://github.com/ice-wm/icewm"
+LICENSE="GPL-2"
+SRC_URI="https://github.com/ice-wm/icewm/releases/download/${PV}/${P}.tar.xz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="+alsa ao bidi debug nls truetype uclibc xinerama"
+
+# Tests broken in all versions, patches welcome, bug #323907, #389533
+RESTRICT="test"
+
+REQUIRED_USE="|| ( alsa ao )"
+
+#fix for icewm preversion package names
+S="${WORKDIR}/${P/_}"
+
+RDEPEND="
+ media-libs/fontconfig
+ x11-libs/gdk-pixbuf:2[X]
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ alsa? (
+ media-libs/alsa-lib
+ media-libs/libsndfile[alsa]
+ )
+ ao? (
+ media-libs/libao
+ media-libs/libsndfile
+ )
+ bidi? ( dev-libs/fribidi )
+ truetype? ( x11-libs/libXext )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="
+ ${RDEPEND}
+ gnome-base/librsvg
+ x11-base/xorg-proto
+ truetype? ( >=media-libs/freetype-2.0.9 )
+"
+
+BDEPEND="
+ app-text/asciidoc
+ nls? ( >=sys-devel/gettext-0.19.6 )
+"
+
+src_prepare() {
+ # Fix bug #486710 - TODO: Still needed?
+ #use uclibc && PATCHES+=( "${FILESDIR}/${PN}-1.3.8-uclibc.patch" )
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local icesound
+ if use alsa && use ao ; then
+ icesound="alsa,ao"
+ elif use alsa ; then
+ icesound="alsa"
+ elif use ao ; then
+ icesound="ao"
+ fi
+
+ local myconf=(
+ --enable-gdk-pixbuf
+ --enable-logevents
+ --enable-xrandr
+ --enable-xrender
+ --with-cfgdir=/etc/icewm
+ --with-docdir=/usr/share/doc/${PF}/html
+ --with-icesound="${icesound}"
+ --with-libdir=/usr/share/icewm
+ $(use_enable bidi fribidi)
+ $(use_enable debug)
+ $(use_enable nls i18n)
+ $(use_enable nls)
+ $(use_enable xinerama)
+ )
+ if use truetype ; then
+ myconf+=(
+ --enable-shape
+ )
+ else
+ myconf+=(
+ --disable-xfreetype
+ --enable-corefonts
+ )
+ fi
+
+ CXXFLAGS="${CXXFLAGS}" econf "${myconf[@]}"
+
+ sed -i "s:/icewm-\$(VERSION)::" src/Makefile || die
+ sed -i "s:ungif:gif:" src/Makefile || die "libungif fix failed"
+}
+
+src_install(){
+ local DOCS=( AUTHORS ChangeLog NEWS README.md TODO VERSION )
+
+ default
+
+ docinto html
+ dodoc doc/icewm.html
+ dodoc man/*.html
+
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}/icewm"
+}