summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-11 04:28:20 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-11 04:56:05 -0400
commit09f4ae308e854bb46cc66df2d10714752f1fdc1d (patch)
tree3cde842a7ccbfa9b226f4fd7af927a89f8912d43 /x11-wm/larswm
parentx11-plugins/wmnet: pass -std=gnu89 (diff)
downloadgentoo-09f4ae308e854bb46cc66df2d10714752f1fdc1d.tar.gz
gentoo-09f4ae308e854bb46cc66df2d10714752f1fdc1d.tar.bz2
gentoo-09f4ae308e854bb46cc66df2d10714752f1fdc1d.zip
x11-wm/larswm: pass -std=gnu89
Does not build with `clang -std=c2x`, early workaround for when this will become a default. (not actively hunting for these, merely revisiting packages previously looked at for clang16 even if not an issue "yet"). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-wm/larswm')
-rw-r--r--x11-wm/larswm/larswm-7.5.3-r2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/x11-wm/larswm/larswm-7.5.3-r2.ebuild b/x11-wm/larswm/larswm-7.5.3-r2.ebuild
index 8adcdfe73021..b19de912b91a 100644
--- a/x11-wm/larswm/larswm-7.5.3-r2.ebuild
+++ b/x11-wm/larswm/larswm-7.5.3-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Tiling window manager for X11, based on 9wm by David Hogan"
HOMEPAGE="http://www.fnurt.net/larswm/"
@@ -25,6 +25,8 @@ BDEPEND="app-text/rman
>=x11-misc/imake-1.0.8-r1"
src_configure() {
+ append-cflags -std=gnu89 # old codebase, incompatible with c2x
+
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf -a || die
}