summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 06:21:57 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:48:15 -0400
commit94f9b8b6e9074bf601fbd12a04cd4f7342621405 (patch)
tree379d465534febe63a7e12b1c7136ec9713b943fe /x11-wm/larswm
parentx11-terms/root-tail: force gcc -E for imake's generation (diff)
downloadgentoo-94f9b8b6e9074bf601fbd12a04cd4f7342621405.tar.gz
gentoo-94f9b8b6e9074bf601fbd12a04cd4f7342621405.tar.bz2
gentoo-94f9b8b6e9074bf601fbd12a04cd4f7342621405.zip
x11-wm/larswm: force gcc -E for imake's generation
Requires traditional cpp support and is broken in all sort of ways with clang-cpp / -E. Can still use clang & friends for everything else. Ideally these packages need to be built another way or last rited, imake will just accumulate more problems. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-wm/larswm')
-rw-r--r--x11-wm/larswm/larswm-7.5.3-r2.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/x11-wm/larswm/larswm-7.5.3-r2.ebuild b/x11-wm/larswm/larswm-7.5.3-r2.ebuild
index 6506e3b2921d..8adcdfe73021 100644
--- a/x11-wm/larswm/larswm-7.5.3-r2.ebuild
+++ b/x11-wm/larswm/larswm-7.5.3-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,16 +17,16 @@ RDEPEND="x11-libs/libX11
x11-libs/libXmu
x11-libs/libXt
x11-libs/libXext"
-DEPEND="${RDEPEND}"
-BDEPEND="
- x11-base/xorg-proto
- >=x11-misc/imake-1.0.8-r1
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="app-text/rman
+ sys-devel/gcc
x11-misc/gccmakedep
- app-text/rman"
+ >=x11-misc/imake-1.0.8-r1"
src_configure() {
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf -a || die
+ IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf -a || die
}
src_compile() {