summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2017-11-24 23:42:28 +0700
committerAndrey Grozin <grozin@gentoo.org>2017-11-24 23:42:28 +0700
commit811b27fd2d43ed22171aeef4d6cb51f6fd87bdd8 (patch)
tree782754941e70888a64bc1dfbef319106ec7b6de4 /x11-wm/lumina
parentmedia-sound/alsamixer-app: update homepage and SRC_URI (diff)
downloadgentoo-811b27fd2d43ed22171aeef4d6cb51f6fd87bdd8.tar.gz
gentoo-811b27fd2d43ed22171aeef4d6cb51f6fd87bdd8.tar.bz2
gentoo-811b27fd2d43ed22171aeef4d6cb51f6fd87bdd8.zip
x11-wm/lumina: bump to 1.4.0
Closes: https://bugs.gentoo.org/638448 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'x11-wm/lumina')
-rw-r--r--x11-wm/lumina/Manifest3
-rw-r--r--x11-wm/lumina/lumina-1.4.0.ebuild74
2 files changed, 76 insertions, 1 deletions
diff --git a/x11-wm/lumina/Manifest b/x11-wm/lumina/Manifest
index 1b2ad87c4fc3..4a69ab661798 100644
--- a/x11-wm/lumina/Manifest
+++ b/x11-wm/lumina/Manifest
@@ -1,2 +1,3 @@
DIST lumina-1.2.0_p1.tar.gz 56032695 SHA256 f8366212fe3f29039c5febef5b4de97a92eb72483e2d97f5c086edf8fc65bd49 SHA512 8490e2b0f2fa08b2d63ec688f9993771ea935129a2947ef7bfa1874424cbede6d8877083ce90658c283858e67397383b5bab536388e9222b440015ebdf8b2919 WHIRLPOOL 6a7fc95022c4f9cc372c4fafc87cbda70a5f3ebcb52dc1f96516460df928e6e2f02ea380104bd7df9f7df33b1d098b24d8e73ec7ffe77e82a633c920634f9c70
-DIST lumina-1.3.0_p1.tar.gz 86451718 SHA256 76f2b6d45d37d154426cb100d46e3ca4e5e7eca51a7f9f9e442261bfe61b1c31 SHA512 93fb195f26984a2ba6e62dbe1ea619e4ab8e936d1cf1d335db8a7e51058c9be8d3e389146259f8229fb5dc6477610dcc2e1278c4e2a348f27904a318ba095707 WHIRLPOOL 6f3af86b66adc66a1b76732e23189946ad35e4897e4bd00912742e3d972bcf0d816b60055098c8ac1104e7e20ce938e7e4727c7501b5e7c92dcb49794c1bb38e
+DIST lumina-1.3.0_p1.tar.gz 86451718 BLAKE2B 7834fad1541144524fc44d5e2cc1af21e82878c05f0cc2da4cf90f8f7e51614f535bab1bcb81c6d5929e14b2fa7ba7df8e66e53a9a81b55c973511f3b3e7cc17 SHA512 93fb195f26984a2ba6e62dbe1ea619e4ab8e936d1cf1d335db8a7e51058c9be8d3e389146259f8229fb5dc6477610dcc2e1278c4e2a348f27904a318ba095707
+DIST lumina-1.4.0.tar.gz 22489118 BLAKE2B 547d062826a6b253cb361db3fb030c182485d335dea3baff7e30f1331c67fbffca619dbee4688f79ac04ff04e5ef2ceeae0c1146d18730a25b7d01125bc62fd3 SHA512 7243fc366a851832d9431df8ae8cac0f70a7bc92bed1282e78e5775c6593d799a07e2cac7042d770c8d6c4758bb142523027d67227a2282b47ed945b0e617cb0
diff --git a/x11-wm/lumina/lumina-1.4.0.ebuild b/x11-wm/lumina/lumina-1.4.0.ebuild
new file mode 100644
index 000000000000..e77758c2ea9f
--- /dev/null
+++ b/x11-wm/lumina/lumina-1.4.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+DESCRIPTION="Lumina desktop environment"
+HOMEPAGE="https://lumina-desktop.org/"
+SRC_URI="https://github.com/trueos/${PN}/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="desktop-utils"
+
+COMMON_DEPEND="dev-qt/qtcore:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtmultimedia:5[widgets]
+ dev-qt/qtsvg:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtgui:5
+ dev-qt/qtdeclarative:5
+ x11-libs/libxcb:0
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm
+ desktop-utils? ( app-text/poppler[qt5] )"
+
+DEPEND="$COMMON_DEPEND
+ dev-qt/linguist-tools:5"
+
+RDEPEND="$COMMON_DEPEND
+ sys-fs/inotify-tools
+ x11-misc/numlockx
+ x11-wm/fluxbox
+ || ( x11-apps/xbacklight
+ sys-power/acpilight )
+ media-sound/alsa-utils
+ sys-power/acpi
+ app-admin/sysstat"
+
+S="${WORKDIR}/${P/_/-}"
+
+PATCHES=(
+ "${FILESDIR}/1.2.0-desktop-files.patch"
+ "${FILESDIR}/1.3.0-OS-detect.patch"
+)
+
+src_prepare(){
+ default
+
+ if use !desktop-utils ; then
+ rm -rf src-qt5/desktop-utils || die
+ sed -e "/desktop-utils/d" -i src-qt5/src-qt5.pro || die
+ fi
+}
+
+src_configure(){
+ eqmake5 PREFIX="${EPREFIX}/usr" LIBPREFIX="${EPREFIX}/usr/$(get_libdir)" \
+ DESTDIR="${D}" CONFIG+=WITH_I18N QMAKE_CFLAGS_ISYSTEM=
+}
+
+src_install(){
+ # A hack to avoid sandbox violation and install liblthemeengine*.so to the correct places
+ emake install INSTALL_ROOT="${D}"
+ rm "${ED%/}"/${PN}-* "${ED%/}"/start-${PN}-desktop "${ED%/}"/liblthemeengine*.so "${ED%/}"/lthemeengine || die
+ mv "${D}/${D}/etc" "${D}/etc" || die
+ mv "${D}/${D}/usr/bin" "${D}/usr/bin" || die
+ mv "${D}/${D}/usr/share" "${D}/usr/share" || die
+ rm -rf "${D}/var" || die
+ mv "${ED%/}"/etc/luminaDesktop.conf{.dist,} || die
+}