summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/marco
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/marco')
-rw-r--r--x11-wm/marco/Manifest2
-rw-r--r--x11-wm/marco/marco-1.8.0.ebuild71
-rw-r--r--x11-wm/marco/marco-1.8.2.ebuild71
-rw-r--r--x11-wm/marco/metadata.xml8
4 files changed, 152 insertions, 0 deletions
diff --git a/x11-wm/marco/Manifest b/x11-wm/marco/Manifest
new file mode 100644
index 000000000000..617713125e18
--- /dev/null
+++ b/x11-wm/marco/Manifest
@@ -0,0 +1,2 @@
+DIST marco-1.8.0.tar.xz 1111780 SHA256 b66f58c87552a20a4533c1ea482d374a35c8921091736e198c2bf1774163a9e6 SHA512 ae6619547b7ebcb27d3baee9612d91a74da99cc7d001d7659a4452855d6c722d4c3bee465ea194e579e61660ce9089d158e4308c78b025ce2848e88e53794023 WHIRLPOOL e33b7a2024c41cbf9c27b0cd1d0423daf17a60d15b2a05c59d66353a9b6349e8c5bcd289e222e4ba24678442a8b9bc7d2fbe3fb0f245767aa615402f4b029ae6
+DIST marco-1.8.2.tar.xz 1119448 SHA256 a5ef03dfd4de035ed6c99aca500256c6f4564a090702066303770dbf7c893443 SHA512 9d8ea38e78a07cd94737bd1da7956b09fba8adc7716b63b281300cdf7c43db1fbed285b6f6085b41bf8ff367e48993ecd230e1ce8a29f3c476d5247274087959 WHIRLPOOL 53ae69ddd5146b6d1342f9ff70d3d5f587befbef25d90d70ae4a2327d3f3b62cb6255ff8840ea88b8d74b8b4b50062a801219dff6b9b6df676726749e4d38027
diff --git a/x11-wm/marco/marco-1.8.0.ebuild b/x11-wm/marco/marco-1.8.0.ebuild
new file mode 100644
index 000000000000..e2ea6f069a91
--- /dev/null
+++ b/x11-wm/marco/marco-1.8.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+# Debug only changes CFLAGS
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="MATE default window manager"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="startup-notification test xinerama"
+
+RDEPEND="
+ dev-libs/atk:0
+ >=dev-libs/glib-2.25.10:2
+ >=mate-extra/mate-dialogs-1.8:0
+ media-libs/libcanberra:0[gtk]
+ >=gnome-base/libgtop-2:2=
+ x11-libs/cairo:0
+ >=x11-libs/pango-1.2:0[X]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libICE:0
+ x11-libs/libSM:0
+ x11-libs/libX11:0
+ >=x11-libs/libXcomposite-0.2:0
+ x11-libs/libXcursor:0
+ x11-libs/libXdamage:0
+ x11-libs/libXext:0
+ x11-libs/libXfixes:0
+ x11-libs/libXrandr:0
+ x11-libs/libXrender:0
+ >=x11-libs/startup-notification-0.7:0
+ virtual/libintl:0
+ xinerama? ( x11-libs/libXinerama:0 )
+ !!x11-wm/mate-window-manager"
+
+DEPEND="${RDEPEND}
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.34.90:*
+ sys-devel/gettext:*
+ virtual/pkgconfig:*
+ x11-proto/xextproto:0
+ x11-proto/xproto:0
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ xinerama? ( x11-proto/xineramaproto:0 )"
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-compositor \
+ --enable-render \
+ --enable-shape \
+ --enable-sm \
+ --enable-xsync \
+ --with-gtk=2.0 \
+ $(use_enable startup-notification) \
+ $(use_enable xinerama)
+}
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README *.txt doc/*.txt"
diff --git a/x11-wm/marco/marco-1.8.2.ebuild b/x11-wm/marco/marco-1.8.2.ebuild
new file mode 100644
index 000000000000..91435e689373
--- /dev/null
+++ b/x11-wm/marco/marco-1.8.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+# Debug only changes CFLAGS
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="MATE default window manager"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="startup-notification test xinerama"
+
+RDEPEND="
+ dev-libs/atk:0
+ >=dev-libs/glib-2.25.10:2
+ >=mate-extra/mate-dialogs-1.8:0
+ media-libs/libcanberra:0[gtk]
+ >=gnome-base/libgtop-2:2=
+ x11-libs/cairo:0
+ >=x11-libs/pango-1.2:0[X]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libICE:0
+ x11-libs/libSM:0
+ x11-libs/libX11:0
+ >=x11-libs/libXcomposite-0.2:0
+ x11-libs/libXcursor:0
+ x11-libs/libXdamage:0
+ x11-libs/libXext:0
+ x11-libs/libXfixes:0
+ x11-libs/libXrandr:0
+ x11-libs/libXrender:0
+ >=x11-libs/startup-notification-0.7:0
+ virtual/libintl:0
+ xinerama? ( x11-libs/libXinerama:0 )
+ !!x11-wm/mate-window-manager"
+
+DEPEND="${RDEPEND}
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.34.90:*
+ sys-devel/gettext:*
+ virtual/pkgconfig:*
+ x11-proto/xextproto:0
+ x11-proto/xproto:0
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ xinerama? ( x11-proto/xineramaproto:0 )"
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-compositor \
+ --enable-render \
+ --enable-shape \
+ --enable-sm \
+ --enable-xsync \
+ --with-gtk=2.0 \
+ $(use_enable startup-notification) \
+ $(use_enable xinerama)
+}
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README *.txt doc/*.txt"
diff --git a/x11-wm/marco/metadata.xml b/x11-wm/marco/metadata.xml
new file mode 100644
index 000000000000..1a53cd0586f6
--- /dev/null
+++ b/x11-wm/marco/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mate</herd>
+ <upstream>
+ <remote-id type="github">mate-desktop/marco</remote-id>
+ </upstream>
+</pkgmetadata>