summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/matwm2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/matwm2')
-rw-r--r--x11-wm/matwm2/Manifest1
-rw-r--r--x11-wm/matwm2/files/matwm2-0.0.96-Makefile.patch23
-rw-r--r--x11-wm/matwm2/files/matwm2.desktop5
-rw-r--r--x11-wm/matwm2/matwm2-0.1.1.ebuild56
-rw-r--r--x11-wm/matwm2/metadata.xml5
5 files changed, 90 insertions, 0 deletions
diff --git a/x11-wm/matwm2/Manifest b/x11-wm/matwm2/Manifest
new file mode 100644
index 000000000000..1e8fb6b98ac5
--- /dev/null
+++ b/x11-wm/matwm2/Manifest
@@ -0,0 +1 @@
+DIST matwm2-0.1.1.tar.gz 64552 SHA256 b85de9adc2118a7305a9015b57183117a4dbebf52b1ae4ac688e8f276319beb7
diff --git a/x11-wm/matwm2/files/matwm2-0.0.96-Makefile.patch b/x11-wm/matwm2/files/matwm2-0.0.96-Makefile.patch
new file mode 100644
index 000000000000..16d86a036d40
--- /dev/null
+++ b/x11-wm/matwm2/files/matwm2-0.0.96-Makefile.patch
@@ -0,0 +1,23 @@
+--- Makefile
++++ Makefile
+@@ -4,10 +4,8 @@
+ CC = cc
+ RM = rm -f
+
+-CFLAGS += -I$(XROOT)/include # remove the + for this and the next line if make complains about being unable to add to a non-existing macro
+-LDFLAGS += -lX11 -L$(XROOT)/lib
+ CFLAGS += -DSHAPE # comment out this line to disable shape support
+-LDFLAGS += -lXext # if shape support is disabled, this normally is no longer necessary and schould probally be commented out too
++LIBS += -lXext -lX11 # if shape support is disabled, this normally is no longer necessary and schould probally be commented out too
+
+ #CFLAGS += -DDEBUG -ggdb3 # -DDEBUG_EVENTS -DSYNC # for debugging
+ CFLAGS += -Wall -Wextra -Wno-unused-parameter
+@@ -19,7 +17,7 @@
+ all: matwm2
+
+ matwm2: $(OBJFILES) $(HEADERS)
+- $(CC) -o $@ $(OBJFILES) $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o $@ $(OBJFILES) $(LIBS)
+
+ clean:
+ $(RM) matwm2 *.o
diff --git a/x11-wm/matwm2/files/matwm2.desktop b/x11-wm/matwm2/files/matwm2.desktop
new file mode 100644
index 000000000000..e15f8e95d0a0
--- /dev/null
+++ b/x11-wm/matwm2/files/matwm2.desktop
@@ -0,0 +1,5 @@
+[Desktop Entry]
+Version=1.0
+Name=matwm2
+Exec=matwm2
+Type=Application
diff --git a/x11-wm/matwm2/matwm2-0.1.1.ebuild b/x11-wm/matwm2/matwm2-0.1.1.ebuild
new file mode 100644
index 000000000000..5c06e5a6a7d7
--- /dev/null
+++ b/x11-wm/matwm2/matwm2-0.1.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="Simple EWMH compatible window manager with titlebars and frames"
+HOMEPAGE="http://squidjam.com/matwm/"
+SRC_URI="http://squidjam.com/matwm/pub/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug xft xinerama"
+
+RDEPEND="
+ x11-libs/libXext
+ x11-libs/libX11
+ debug? ( x11-proto/xproto )
+ xft? ( x11-libs/libXft )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xextproto
+ xinerama? ( x11-proto/xineramaproto )
+"
+
+src_configure() {
+ # configure is not autotools based
+ # --disable-shape left out because the code is broken
+ ./configure \
+ $( use debug && echo --enable-debug ) \
+ $( use xft || echo --disable-xft ) \
+ $( use xinerama || echo --disable-xinerama ) \
+ || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc BUGS ChangeLog default_matwmrc README TODO
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/${PN}.desktop
+
+ echo ${PN} > "${T}"/${PN}
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/${PN}
+}
diff --git a/x11-wm/matwm2/metadata.xml b/x11-wm/matwm2/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/x11-wm/matwm2/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>