summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-07-12 15:45:55 +0300
committerMart Raudsepp <leio@gentoo.org>2020-07-13 00:02:48 +0300
commit8e1b625bdc162675f8a67f3b60aa5c33b65da0d4 (patch)
treee5b9d77097db6570fb9edb958a2d2e82039c2fe1 /x11-wm/metacity/metacity-3.36.1.ebuild
parentgnome-base/gnome-applets: bump to 3.36.4 (diff)
downloadgentoo-8e1b625bdc162675f8a67f3b60aa5c33b65da0d4.tar.gz
gentoo-8e1b625bdc162675f8a67f3b60aa5c33b65da0d4.tar.bz2
gentoo-8e1b625bdc162675f8a67f3b60aa5c33b65da0d4.zip
x11-wm/metacity: bump to 3.36.1
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'x11-wm/metacity/metacity-3.36.1.ebuild')
-rw-r--r--x11-wm/metacity/metacity-3.36.1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/x11-wm/metacity/metacity-3.36.1.ebuild b/x11-wm/metacity/metacity-3.36.1.ebuild
new file mode 100644
index 000000000000..bc33e8f6558b
--- /dev/null
+++ b/x11-wm/metacity/metacity-3.36.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="GNOME Flashback window manager"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/metacity/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+libcanberra vulkan xinerama"
+KEYWORDS="~amd64"
+
+# TODO: libgtop could be optional, but no knob
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+ >=x11-libs/gtk+-3.22.0:3[X]
+ >=x11-libs/pango-1.2.0
+ >=x11-libs/libXcomposite-0.3
+ >=gnome-base/gsettings-desktop-schemas-3.3.0
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXdamage
+ libcanberra? ( media-libs/libcanberra[gtk3] )
+ >=x11-libs/startup-notification-0.7
+ x11-libs/libXcursor
+ gnome-base/libgtop:2=
+ x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )
+ x11-libs/libXrandr
+ x11-libs/libXext
+ x11-libs/libICE
+ x11-libs/libSM
+ gnome-extra/zenity
+ vulkan? ( media-libs/vulkan-loader )
+"
+DEPEND="${RDEPEND}
+ vulkan? ( dev-util/vulkan-headers )
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.4
+ x11-base/xorg-proto
+ virtual/pkgconfig
+" # autoconf-archive for eautoreconf
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable libcanberra canberra) \
+ $(use_enable xinerama) \
+ $(use_enable vulkan)
+}