summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharbel Assaad <sydiepus@gmail.com>2022-10-12 12:55:28 +0300
committerSam James <sam@gentoo.org>2022-12-24 07:55:09 +0000
commita2c106a2f01fcb3bdc49ad0c5d9171eee0fdbdf2 (patch)
treeb1806edb126b55aa455e117653bccd8bebf19b2b /x11-wm/qtile
parentwww-apps/redmine: drop 4.2.7, 5.0.2 (diff)
downloadgentoo-a2c106a2f01fcb3bdc49ad0c5d9171eee0fdbdf2.tar.gz
gentoo-a2c106a2f01fcb3bdc49ad0c5d9171eee0fdbdf2.tar.bz2
gentoo-a2c106a2f01fcb3bdc49ad0c5d9171eee0fdbdf2.zip
x11-wm/qtile: add 0.22.1, 9999
- Add 0.22.1 - Add 9999 - Use qtile-wayland.desktop provided by the package instead of the one provided by the ebuild for qtile-0.21.0-r1.ebuild Signed-off-by: Charbel Assaad <sydiepus@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-wm/qtile')
-rw-r--r--x11-wm/qtile/Manifest1
-rw-r--r--x11-wm/qtile/files/qtile.desktop6
-rw-r--r--x11-wm/qtile/qtile-0.21.0-r1.ebuild2
-rw-r--r--x11-wm/qtile/qtile-0.22.1.ebuild79
-rw-r--r--x11-wm/qtile/qtile-9999.ebuild79
5 files changed, 160 insertions, 7 deletions
diff --git a/x11-wm/qtile/Manifest b/x11-wm/qtile/Manifest
index 23e4e78ebf39..75d09b99af46 100644
--- a/x11-wm/qtile/Manifest
+++ b/x11-wm/qtile/Manifest
@@ -1 +1,2 @@
DIST qtile-0.21.0.tar.gz 475428 BLAKE2B 8c63eb8776fb6feab30c7ee2a19e6f28df6715fc18b09c63b89de6bf2129cd3c5c516d0c9efc946f24590fa8afc6e87c704c8e3b7094d0843b5b6e34df57ca18 SHA512 b7c5fc478180413e263445316ac9560c1d22668194415c3e4edae5c672f4b317fd978083dc9a985f0d145aeaaa55ffab0017e83af963f30d8b36f9963e12b079
+DIST qtile-0.22.1.tar.gz 488969 BLAKE2B 3b2fce587ae39570997b503cb386314160dbefa39b1ef65dc2ff5bc2f1167251224a0f298ef8e374d0d4c034d1e5012251f96b92ce5cb74d7fd93320e14ff8bf SHA512 944ec27b5d227154624fa2a15a0840b748307a1e79ab52ccf3384763111459b3c4d26b4677f8e2ea51634206dc6d1e32e057e057db917b3705ce583d83a8056d
diff --git a/x11-wm/qtile/files/qtile.desktop b/x11-wm/qtile/files/qtile.desktop
deleted file mode 100644
index 5b00f85a88c0..000000000000
--- a/x11-wm/qtile/files/qtile.desktop
+++ /dev/null
@@ -1,6 +0,0 @@
-[Desktop Entry]
-Name=Qtile
-Comment=Qtile Wayland Session
-Exec=qtile start -b wayland
-Type=Application
-Keywords=wm;tiling
diff --git a/x11-wm/qtile/qtile-0.21.0-r1.ebuild b/x11-wm/qtile/qtile-0.21.0-r1.ebuild
index 4bdd86e614c8..139993950102 100644
--- a/x11-wm/qtile/qtile-0.21.0-r1.ebuild
+++ b/x11-wm/qtile/qtile-0.21.0-r1.ebuild
@@ -66,7 +66,7 @@ python_install_all() {
doins resources/qtile.desktop
insinto /usr/share/wayland-sessions
- doins "${FILESDIR}"/qtile.desktop
+ doins resources/qtile-wayland.desktop
exeinto /etc/X11/Sessions
newexe "${FILESDIR}"/${PN}-session-r1 ${PN}
diff --git a/x11-wm/qtile/qtile-0.22.1.ebuild b/x11-wm/qtile/qtile-0.22.1.ebuild
new file mode 100644
index 000000000000..11d0d1fd538d
--- /dev/null
+++ b/x11-wm/qtile/qtile-0.22.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="A full-featured, hackable tiling window manager written in Python"
+HOMEPAGE="http://qtile.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/qtile/qtile.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=">=dev-python/cairocffi-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.1.0[${PYTHON_USEDEP}]
+ dev-python/dbus-next[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/xcffib-0.10.1[${PYTHON_USEDEP}]
+ media-sound/pulseaudio
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/libnotify[introspection]
+ x11-libs/pango"
+BDEPEND="
+ test? (
+ media-gfx/imagemagick[X]
+ x11-base/xorg-server[xephyr]
+ )"
+
+EPYTEST_DESELECT=(
+ # Can't find built qtile like migrate
+ test/test_qtile_cmd.py::test_qtile_cmd
+ test/test_qtile_cmd.py::test_display_kb
+)
+
+EPYTEST_IGNORE=(
+ # Tries to find binary and fails; not worth running anyway?
+ test/test_migrate.py
+)
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ # Force usage of built module
+ rm -rf "${S}"/libqtile || die
+
+ epytest || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG README.rst )
+ distutils-r1_python_install_all
+
+ insinto /usr/share/xsessions
+ doins resources/qtile.desktop
+
+ insinto /usr/share/wayland-sessions
+ doins resources/qtile-wayland.desktop
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/${PN}-session-r1 ${PN}
+}
diff --git a/x11-wm/qtile/qtile-9999.ebuild b/x11-wm/qtile/qtile-9999.ebuild
new file mode 100644
index 000000000000..11d0d1fd538d
--- /dev/null
+++ b/x11-wm/qtile/qtile-9999.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="A full-featured, hackable tiling window manager written in Python"
+HOMEPAGE="http://qtile.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/qtile/qtile.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=">=dev-python/cairocffi-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.1.0[${PYTHON_USEDEP}]
+ dev-python/dbus-next[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/xcffib-0.10.1[${PYTHON_USEDEP}]
+ media-sound/pulseaudio
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/libnotify[introspection]
+ x11-libs/pango"
+BDEPEND="
+ test? (
+ media-gfx/imagemagick[X]
+ x11-base/xorg-server[xephyr]
+ )"
+
+EPYTEST_DESELECT=(
+ # Can't find built qtile like migrate
+ test/test_qtile_cmd.py::test_qtile_cmd
+ test/test_qtile_cmd.py::test_display_kb
+)
+
+EPYTEST_IGNORE=(
+ # Tries to find binary and fails; not worth running anyway?
+ test/test_migrate.py
+)
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ # Force usage of built module
+ rm -rf "${S}"/libqtile || die
+
+ epytest || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG README.rst )
+ distutils-r1_python_install_all
+
+ insinto /usr/share/xsessions
+ doins resources/qtile.desktop
+
+ insinto /usr/share/wayland-sessions
+ doins resources/qtile-wayland.desktop
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/${PN}-session-r1 ${PN}
+}