summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-05-15 08:31:00 +0200
committerJeroen Roovers <jer@gentoo.org>2020-05-15 08:42:49 +0200
commitcb1778f55abab8dca9adc847cbdc6e22c67c1ce1 (patch)
tree6c2ac9805280a8d8554cfb0aac7f9bb2de6d10ed /x11-wm/sawfish
parentdev-libs/librep: Version 0.92.7 (diff)
downloadgentoo-cb1778f55abab8dca9adc847cbdc6e22c67c1ce1.tar.gz
gentoo-cb1778f55abab8dca9adc847cbdc6e22c67c1ce1.tar.bz2
gentoo-cb1778f55abab8dca9adc847cbdc6e22c67c1ce1.zip
x11-wm/sawfish: Fix building with CFLAGS=-fno-common
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Closes: https://bugs.gentoo.org/show_bug.cgi?id=708024 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-wm/sawfish')
-rw-r--r--x11-wm/sawfish/files/sawfish-1.12.0-fno-common.patch39
-rw-r--r--x11-wm/sawfish/sawfish-1.12.0-r1.ebuild3
2 files changed, 41 insertions, 1 deletions
diff --git a/x11-wm/sawfish/files/sawfish-1.12.0-fno-common.patch b/x11-wm/sawfish/files/sawfish-1.12.0-fno-common.patch
new file mode 100644
index 000000000000..73f58be99eea
--- /dev/null
+++ b/x11-wm/sawfish/files/sawfish-1.12.0-fno-common.patch
@@ -0,0 +1,39 @@
+--- a/src/functions.c
++++ b/src/functions.c
+@@ -65,7 +65,7 @@
+ # endif
+ #endif
+
+-DEFSYM(root, "root");
++extern DEFSYM(root, "root");
+ DEFSYM(after_restacking_hook, "after-restacking-hook");
+ DEFSYM(position, "position");
+ DEFSYM(spacing, "spacing");
+--- a/src/flippers.c
++++ b/src/flippers.c
+@@ -22,10 +22,10 @@
+
+ static Window edge_left, edge_right, edge_top, edge_bottom;
+
+-DEFSYM(left, "left");
+-DEFSYM(right, "right");
+-DEFSYM(top, "top");
+-DEFSYM(bottom, "bottom");
++extern DEFSYM(left, "left");
++extern DEFSYM(right, "right");
++extern DEFSYM(top, "top");
++extern DEFSYM(bottom, "bottom");
+ DEFSYM(enter_flipper_hook, "enter-flipper-hook");
+ DEFSYM(leave_flipper_hook, "leave-flipper-hook");
+
+--- a/src/windows.c
++++ b/src/windows.c
+@@ -75,7 +75,7 @@
+ DEFSYM(north, "north");
+ DEFSYM(north_east, "north-east");
+ DEFSYM(west, "west");
+-DEFSYM(center, "center");
++extern DEFSYM(center, "center");
+ DEFSYM(east, "east");
+ DEFSYM(south_west, "south-west");
+ DEFSYM(south, "south");
diff --git a/x11-wm/sawfish/sawfish-1.12.0-r1.ebuild b/x11-wm/sawfish/sawfish-1.12.0-r1.ebuild
index 2cc5b3ad24c2..726c0ecafee0 100644
--- a/x11-wm/sawfish/sawfish-1.12.0-r1.ebuild
+++ b/x11-wm/sawfish/sawfish-1.12.0-r1.ebuild
@@ -34,7 +34,8 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
# From Fedora
- "${FILESDIR}"/${P}-desktop.patch
+ "${FILESDIR}"/${PN}-1.12.0-desktop.patch
+ "${FILESDIR}"/${PN}-1.12.0-fno-common.patch
)
DOCS=( AUTHORS ChangeLog CONTRIBUTING doc/AUTOSTART doc/KEYBINDINGS doc/OPTIONS doc/XSettings MAINTAINERS NEWS README README.IMPORTANT TODO )