summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2020-06-25 13:13:23 -0500
committerBen Kohler <bkohler@gentoo.org>2020-06-25 13:13:36 -0500
commite9435892c182de3e4515df6130e68ce5e53a6ca6 (patch)
tree17574c7042b43c193378b7b363ba019b368bde15 /x11-wm/spectrwm/spectrwm-3.4.1.ebuild
parentx11-misc/obmenu-generator: bump to 0.88 (diff)
downloadgentoo-e9435892c182de3e4515df6130e68ce5e53a6ca6.tar.gz
gentoo-e9435892c182de3e4515df6130e68ce5e53a6ca6.tar.bz2
gentoo-e9435892c182de3e4515df6130e68ce5e53a6ca6.zip
x11-wm/spectrwm: bump to 3.4.1
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'x11-wm/spectrwm/spectrwm-3.4.1.ebuild')
-rw-r--r--x11-wm/spectrwm/spectrwm-3.4.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-wm/spectrwm/spectrwm-3.4.1.ebuild b/x11-wm/spectrwm/spectrwm-3.4.1.ebuild
new file mode 100644
index 000000000000..67195eaf70bb
--- /dev/null
+++ b/x11-wm/spectrwm/spectrwm-3.4.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit desktop multilib toolchain-funcs
+
+DESCRIPTION="Small dynamic tiling window manager for X11"
+HOMEPAGE="https://github.com/conformal/spectrwm"
+SRC_URI="https://github.com/conformal/spectrwm/archive/${PN^^}_${PV//./_}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ !x11-wm/scrotwm
+ x11-misc/dmenu
+"
+DEPEND="
+ elibc_musl? ( sys-libs/queue-standalone )
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXt
+ x11-libs/xcb-util
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.4.0-gentoo.patch
+)
+S=${WORKDIR}/${PN}-${PN^^}_${PV//./_}
+
+src_prepare() {
+ sed -i -e '/LICENSE.md/d' linux/Makefile || die
+ default
+}
+
+src_compile() {
+ tc-export CC PKG_CONFIG
+ emake -C linux PREFIX="${EROOT}/usr" LIBDIR="${EROOT}/usr/$(get_libdir)"
+}
+
+src_install() {
+ emake -C linux PREFIX="${EROOT}/usr" LIBDIR="${EROOT}/usr/$(get_libdir)" \
+ SYSCONFDIR="${EROOT}/etc" DOCDIR="${EROOT}/usr/share/doc/${P}" \
+ DESTDIR="${D}" install
+
+ dodoc README.md ${PN}_*.conf {initscreen,screenshot}.sh
+}