summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2018-01-28 15:08:40 +0100
committerChema Alonso Josa <nimiux@gentoo.org>2018-01-28 15:09:10 +0100
commit3b512754e6654558655c3aadff37681892e3b724 (patch)
tree67b79d782e3ebc3d62bdbeb069f1ff393fe9d7df /x11-wm/stumpwm-contrib/stumpwm-contrib-20180128.ebuild
parentmedia-libs/openexr: amd64 stable wrt bug #639804 (diff)
downloadgentoo-3b512754e6654558655c3aadff37681892e3b724.tar.gz
gentoo-3b512754e6654558655c3aadff37681892e3b724.tar.bz2
gentoo-3b512754e6654558655c3aadff37681892e3b724.zip
x11-wm/stumpwm-contrib: Bumps snapshot to 20180128
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'x11-wm/stumpwm-contrib/stumpwm-contrib-20180128.ebuild')
-rw-r--r--x11-wm/stumpwm-contrib/stumpwm-contrib-20180128.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-wm/stumpwm-contrib/stumpwm-contrib-20180128.ebuild b/x11-wm/stumpwm-contrib/stumpwm-contrib-20180128.ebuild
new file mode 100644
index 000000000000..fbd35c2db101
--- /dev/null
+++ b/x11-wm/stumpwm-contrib/stumpwm-contrib-20180128.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3
+
+DESCRIPTION="Extension Modules for StumpWM"
+HOMEPAGE="https://github.com/stumpwm/stumpwm-contrib/"
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="${HOMEPAGE}"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 GPL-3 BSD-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=x11-wm/stumpwm-1.0.0"
+
+CONTRIBCATEGORIES="media minor-mode modeline util"
+
+src_install() {
+ common-lisp-install-sources -t all ${CONTRIBCATEGORIES}
+ dobin util/stumpish/stumpish
+ dobin util/pinentry/stumpwm-pinentry
+ dodoc README.org
+}