summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/vtwm/vtwm-5.4.7-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/vtwm/vtwm-5.4.7-r1.ebuild')
-rw-r--r--x11-wm/vtwm/vtwm-5.4.7-r1.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/x11-wm/vtwm/vtwm-5.4.7-r1.ebuild b/x11-wm/vtwm/vtwm-5.4.7-r1.ebuild
new file mode 100644
index 000000000000..4c79db3ba790
--- /dev/null
+++ b/x11-wm/vtwm/vtwm-5.4.7-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="one of many TWM descendants and implements a Virtual Desktop"
+HOMEPAGE="http://www.vtwm.org/"
+SRC_URI="http://www.vtwm.org/downloads/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~ppc ~sparc ~x86"
+IUSE="rplay"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXext
+ x11-libs/libXpm
+ rplay? ( media-sound/rplay )"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ x11-misc/imake
+ app-text/rman
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-do-not-rm.patch
+ sed -i Imakefile \
+ -e 's:-L/usr/local/lib::g' \
+ -e 's:-I/usr/local/include::g' \
+ || die "sed Imakefile"
+ if ! use rplay ; then
+ sed -i Imakefile \
+ -e 's:^XCOMM\ \(.*NO_SOUND\):\1:' \
+ -e 's:^\(SOUNDLIB.*\):XCOMM\ \1:' \
+ -e 's:sound\..::g' \
+ || die "sed Imakefile"
+ epatch "${FILESDIR}"/${P}-NO_SOUND_SUPPORT.patch
+ fi
+}
+
+src_configure() {
+ xmkmf || die "xmkmf failed"
+ emake depend || die "emake depend"
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CCOPTIONS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake BINDIR=/usr/bin \
+ LIBDIR=/etc/X11 \
+ MANPATH=/usr/share/man \
+ DESTDIR="${D}" install || die "emake install failed"
+
+ echo "#!/bin/sh" > vtwm
+ echo "xsetroot -cursor_name left_ptr &" >> vtwm
+ echo "/usr/bin/vtwm" >> vtwm
+ exeinto /etc/X11/Sessions
+ doexe vtwm || die
+ dodoc doc/{4.7.*,CHANGELOG,BUGS,DEVELOPERS,HISTORY,SOUND,WISHLIST} || die
+}