summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/windowlab/windowlab-1.34.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/windowlab/windowlab-1.34.ebuild')
-rw-r--r--x11-wm/windowlab/windowlab-1.34.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/x11-wm/windowlab/windowlab-1.34.ebuild b/x11-wm/windowlab/windowlab-1.34.ebuild
new file mode 100644
index 000000000000..5dd232c87ae4
--- /dev/null
+++ b/x11-wm/windowlab/windowlab-1.34.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="small and simple window manager of novel design"
+HOMEPAGE="http://www.nickgravgaard.com/windowlab/"
+SRC_URI="http://www.nickgravgaard.com/${PN}/${P}.tar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc x86"
+IUSE="truetype"
+
+RDEPEND="truetype? ( x11-libs/libXft )
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.34-fixed-font.patch"
+}
+
+src_compile() {
+ if use truetype ; then
+ export DEFINES=-DXFT
+ export EXTRA_INC=$(pkg-config --cflags xft)
+ export EXTRA_LIBS=$(pkg-config --libs xft)
+ fi
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin ${PN} || die
+
+ newman ${PN}.1x ${PN}.1 || die
+ dodoc CHANGELOG README TODO || die
+
+ dodir /etc/X11/${PN} || die
+ insinto /etc/X11/${PN}
+ doins ${PN}.menurc || die
+
+ dodir /etc/X11/Sessions || die
+ echo "/usr/bin/${PN}" > ${D}/etc/X11/Sessions/${PN}
+ fperms a+x /etc/X11/Sessions/${PN}
+}
+
+pkg_postinst() {
+ elog "${PN}'s menu config file has been changed from"
+ elog "/etc/X11/${PN}/menurc to /etc/X11/${PN}/${PN}.menurc"
+}