summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-04-29 10:32:24 +0100
committerJames Le Cuirot <chewi@gentoo.org>2022-04-29 10:32:24 +0100
commit00a81436f2ea48adaf8f17168e4af4749e2973ac (patch)
tree708f4e4e4d6a9cf1e835da7f0aa4f19c9eabaa94 /x11-wm
parentsys-kernel/dracut: stabilize 055-r4 for hppa (diff)
downloadgentoo-00a81436f2ea48adaf8f17168e4af4749e2973ac.tar.gz
gentoo-00a81436f2ea48adaf8f17168e4af4749e2973ac.tar.bz2
gentoo-00a81436f2ea48adaf8f17168e4af4749e2973ac.zip
x11-wm/xpra: Version bump to 4.3.3
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/xpra/Manifest1
-rw-r--r--x11-wm/xpra/xpra-4.3.3.ebuild203
2 files changed, 204 insertions, 0 deletions
diff --git a/x11-wm/xpra/Manifest b/x11-wm/xpra/Manifest
index b75a51d00781..b930ca5f5341 100644
--- a/x11-wm/xpra/Manifest
+++ b/x11-wm/xpra/Manifest
@@ -1,3 +1,4 @@
DIST xpra-4.2.tar.gz 4057304 BLAKE2B 17b6a95f7ce24a311c39d09291d9570285c30f25c2d935389cb380c2fce698acd984821e69acaabd66368e76b5beddd01803a68d6a16dd930dd2fa3289532f10 SHA512 261d46c04ce70686f41873c5c0c115e462e3b2501c58ab05fb2904f4700454c5fb8124d0faf86fe5e982872f19a4b90b941f8aff4790f7206602d6030c005353
DIST xpra-4.3.1-tests.patch 51444 BLAKE2B c645aa52bb06c3872f6c1c7aace099c10a6fd46dd4c386ec1a13f6326e3fc8860a71767510ce9b44375cc8b30cef563e4405b2834670a9d2c555d3359d16e99f SHA512 0c70c33e24980db31e904c91f987a73693bd2349958ea8392138987e1dc1852ea42a4ee7e3b238f01c92adc57dbe196e57f4c4accf27aade6c4ea55c1ff9b40c
DIST xpra-4.3.2.tar.gz 4175968 BLAKE2B 16d42f9509c1ac3cf3f345a6cdd3711496019064c890268d1c1612e37e34ffe93016488f8a6d1bf8509da1d32500571e80bb4143a2f870f07530386515107735 SHA512 b9bc89a0d042e4ef2a416b7787bd1588a9d151d482319c637073749383e2b3f3361eb0f95c0e39ba98c9ae87ef5acb68c4980645fb9a2feea37215f88f7a8a95
+DIST xpra-4.3.3.tar.gz 4180278 BLAKE2B 2fceab6c95efd0bd0390b7965aea588f39e43f86094c1f9921e1f75022f569808e27d7d85adcccfd64ac28889d0f6d2d6afdf4365f8c919bac8b1a14f3919f23 SHA512 c470e892b4b6379b6c9447731ab174e85c26de15fdc9541a199a2f49e45d07942ae8638f8ddf040a22c73422c6e6b262a9066cd8990f182b75163f7d449d91e2
diff --git a/x11-wm/xpra/xpra-4.3.3.ebuild b/x11-wm/xpra/xpra-4.3.3.ebuild
new file mode 100644
index 000000000000..337531a3c0f3
--- /dev/null
+++ b/x11-wm/xpra/xpra-4.3.3.ebuild
@@ -0,0 +1,203 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/Xpra-org/xpra.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://dev.gentoo.org/~chewi/distfiles/${PN}-4.3.1-tests.patch"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+DISTUTILS_SINGLE_IMPL=yes
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit xdg xdg-utils distutils-r1 tmpfiles udev
+
+DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based on wimpiggy"
+HOMEPAGE="https://xpra.org/"
+LICENSE="GPL-2 BSD"
+SLOT="0"
+IUSE="brotli +client +clipboard csc cups dbus doc ffmpeg jpeg html ibus +lz4 lzo minimal opengl pillow pinentry pulseaudio +server sound systemd test vpx webcam webp xdg xinerama"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ || ( client server )
+ cups? ( dbus )
+ opengl? ( client )
+ test? ( client clipboard dbus html server sound xdg xinerama )
+"
+
+TDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/netifaces[${PYTHON_USEDEP}]
+ dev-python/pillow[jpeg?,${PYTHON_USEDEP}]
+ dev-python/rencode[${PYTHON_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ xdg? ( dev-python/pyxdg[${PYTHON_USEDEP}] )
+ ')
+ html? ( www-apps/xpra-html5 )
+ server? (
+ x11-base/xorg-server[-minimal,xvfb]
+ x11-drivers/xf86-input-void
+ )
+ xinerama? ( x11-libs/libfakeXinerama )
+"
+DEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
+ sound? ( dev-python/gst-python:1.0[${PYTHON_USEDEP}] )
+ ')
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXres
+ x11-libs/libXtst
+ x11-libs/libxkbfile
+ brotli? ( app-arch/brotli )
+ csc? ( >=media-video/ffmpeg-1.2.2:0= )
+ ffmpeg? ( >=media-video/ffmpeg-3.2.2:0=[x264,x265] )
+ jpeg? ( media-libs/libjpeg-turbo )
+ pulseaudio? (
+ media-sound/pulseaudio
+ media-plugins/gst-plugins-pulse:1.0
+ )
+ sound? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ )
+ vpx? ( media-libs/libvpx media-video/ffmpeg )
+ webp? ( media-libs/libwebp )
+"
+RDEPEND="
+ ${DEPEND}
+ ${TDEPEND}
+ $(python_gen_cond_dep '
+ cups? ( dev-python/pycups[${PYTHON_USEDEP}] )
+ lz4? ( dev-python/lz4[${PYTHON_USEDEP}] )
+ lzo? ( >=dev-python/python-lzo-0.7.0[${PYTHON_USEDEP}] )
+ opengl? (
+ client? ( dev-python/pyopengl_accelerate[${PYTHON_USEDEP}] )
+ )
+ webcam? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyinotify[${PYTHON_USEDEP}]
+ media-libs/opencv[${PYTHON_USEDEP},python]
+ )
+ ')
+ acct-group/xpra
+ virtual/ssh
+ x11-apps/xauth
+ x11-apps/xmodmap
+ ibus? ( app-i18n/ibus )
+ pinentry? ( app-crypt/pinentry )
+"
+DEPEND+="
+ test? ( ${TDEPEND} )
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/cython-0.16[${PYTHON_USEDEP}]
+ ')
+ virtual/pkgconfig
+ doc? ( app-text/pandoc )
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.2_ignore-gentoo-no-compile.patch
+ "${FILESDIR}"/${PN}-4.2-suid-warning.patch
+ "${FILESDIR}"/${PN}-4.3-no-service.patch
+ "${DISTDIR}"/${PN}-4.3.1-tests.patch
+)
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # FIXME: There are hardcoded paths all over the place but the following
+ # double-prefixes some files under /etc. Looks tricky to fix. :(
+ #hprefixify $(find -type f \( -name "*.py" -o -name "*.conf" \))
+
+ sed -r -e "/\bdoc_dir =/s:/${PN}\":/${PF}/html\":" \
+ -i setup.py || die
+
+ if use minimal; then
+ sed -r -e 's/^(pam|scripts|xdg_open)_ENABLED.*/\1_ENABLED=False/' \
+ -i setup.py || die
+ fi
+}
+
+python_configure_all() {
+ sed -e "/'pulseaudio'/s:DEFAULT_PULSEAUDIO:$(usex pulseaudio True False):" \
+ -i setup.py || die
+
+ DISTUTILS_ARGS=(
+ --without-PIC
+ --without-Xdummy
+ $(use_with client)
+ $(use_with clipboard)
+ $(use_with csc csc_swscale)
+ --without-csc_libyuv
+ --without-cuda_rebuild
+ --without-cuda_kernels
+ $(use_with cups printing)
+ --without-debug
+ $(use_with dbus)
+ $(use_with doc docs)
+ $(use_with ffmpeg dec_avcodec2)
+ $(use_with ffmpeg enc_ffmpeg)
+ $(use_with ffmpeg enc_x264)
+ $(use_with ffmpeg enc_x265)
+ --with-gtk3
+ $(use_with jpeg jpeg_encoder)
+ $(use_with jpeg jpeg_decoder)
+ --without-mdns
+ $(use_with opengl)
+ $(use_with server shadow)
+ $(use_with server)
+ $(use_with sound)
+ --with-strict
+ $(use_with vpx)
+ --with-warn
+ $(use_with webcam)
+ $(use_with webp)
+ --with-x11
+ )
+
+ export XPRA_SOCKET_DIRS="${EPREFIX}/run/xpra"
+}
+
+python_test() {
+ export XAUTHORITY=${HOME}/.Xauthority
+ touch "${XAUTHORITY}" || die
+
+ distutils_install_for_testing
+ xdg_environment_reset
+
+ PYTHONPATH=${S}/tests/unittests:${BUILD_DIR}/test/lib \
+ XPRA_SYSTEMD_RUN=$(usex systemd) XPRA_TEST_COVERAGE=0 \
+ "${PYTHON}" "${S}"/tests/unittests/unit/run.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_prepare_all
+
+ # Move udev dir to the right place.
+ local dir=$(get_udevdir)
+ dodir "${dir%/*}"
+ mv -vnT "${ED}"/usr/lib/udev "${ED}${dir}" || die
+}
+
+pkg_postinst() {
+ tmpfiles_process xpra.conf
+ xdg_pkg_postinst
+}