summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-01-04 17:56:56 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-01-04 18:19:16 +0200
commit188d57066588dde9c49afa376f7d5f1080b17fa1 (patch)
tree7de9312cc7f3c283d083e06c004b2144d7426845 /x11-wm
parentsys-apps/memtest86+: drop old (diff)
downloadgentoo-188d57066588dde9c49afa376f7d5f1080b17fa1.tar.gz
gentoo-188d57066588dde9c49afa376f7d5f1080b17fa1.tar.bz2
gentoo-188d57066588dde9c49afa376f7d5f1080b17fa1.zip
x11-wm/enlightenment: add 0.25.1
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/enlightenment/Manifest1
-rw-r--r--x11-wm/enlightenment/enlightenment-0.25.1.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/x11-wm/enlightenment/Manifest b/x11-wm/enlightenment/Manifest
index b507b5b08430..07d702c1bc9d 100644
--- a/x11-wm/enlightenment/Manifest
+++ b/x11-wm/enlightenment/Manifest
@@ -1 +1,2 @@
DIST enlightenment-0.24.2.tar.xz 28716060 BLAKE2B 432722693beaece97eeb318a1120b6101bf76e1536347b824b00ba4378326c093f3333eefa634d7266a59c09dc4337c8bd1f9a4d89e0a4c9a223fdcacd924fa0 SHA512 5d96b17d89e822271048a0a6a8356658fd02680f54da2f15dde7c632752bbf0a396eaf23986164402e61f631e68937b3ba7c29d9dd787ddd470cff4a390abace
+DIST enlightenment-0.25.1.tar.xz 405708428 BLAKE2B 14d70880534992673ad3c0ff8adbbc3ae0ec4f3c8f9a935d6e07c6642a2874710270bbb2bb2fab741aaa615779465c4a609ec200098e402673a0ee1af733fbbc SHA512 b64521adb725bb04455d0512e884e77c79cabbf3ecf28765a02d002672aaf261a2a6c98c9d1d3dc85baac84d9637b8217500249ea74833b35d87c88194ee1da1
diff --git a/x11-wm/enlightenment/enlightenment-0.25.1.ebuild b/x11-wm/enlightenment/enlightenment-0.25.1.ebuild
new file mode 100644
index 000000000000..5af2072bad8b
--- /dev/null
+++ b/x11-wm/enlightenment/enlightenment-0.25.1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature xdg
+
+DESCRIPTION="Enlightenment window manager"
+HOMEPAGE="https://www.enlightenment.org"
+SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0.17/${PV%%_*}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="acpi bluetooth connman doc exif geolocation nls pam policykit systemd udisks wayland xwayland"
+
+REQUIRED_USE="xwayland? ( wayland )"
+
+RDEPEND=">=dev-libs/efl-1.26.1[eet,fontconfig,X]
+ virtual/udev
+ x11-libs/libXext
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+ x11-misc/xkeyboard-config
+ acpi? ( sys-power/acpid )
+ bluetooth? ( net-wireless/bluez )
+ connman? ( dev-libs/efl[connman] )
+ exif? ( media-libs/libexif )
+ geolocation? ( app-misc/geoclue:2.0 )
+ pam? ( sys-libs/pam )
+ policykit? ( sys-auth/polkit )
+ systemd? ( sys-apps/systemd )
+ udisks? ( sys-fs/udisks:2 )
+ wayland? (
+ || (
+ dev-libs/efl[systemd]
+ dev-libs/efl[elogind]
+ )
+ dev-libs/efl[drm,wayland]
+ dev-libs/wayland
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ )
+ xwayland? (
+ dev-libs/efl[X,wayland]
+ x11-base/xwayland
+ )"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ -D device-udev=true
+ -D elput=true
+ -D install-enlightenment-menu=true
+
+ -D install-sysactions=true
+ -D install-system=true
+ -D mount-eeze=false
+
+ -D packagekit=false
+
+ $(meson_use udisks mount-udisks)
+ $(meson_use bluetooth bluez5)
+ $(meson_use connman)
+ $(meson_use exif libexif)
+ $(meson_use geolocation)
+ $(meson_use nls)
+ $(meson_use pam)
+ $(meson_use policykit polkit)
+ $(meson_use systemd)
+ $(meson_use wayland wl)
+ $(meson_use xwayland)
+ )
+
+ if ! use wayland; then
+ emesonargs+=(
+ -D wl-buffer=false
+ -D wl-desktop-shell=false
+ -D wl-drm=false
+ -D wl-text-input=false
+ -D wl-weekeyboard=false
+ -D wl-wl=false
+ -D wl-x11=false
+ )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/. )
+ meson_src_install
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+
+ optfeature_header "Additional programs to complement the full EFL suite:"
+ optfeature "efl-based pinentry interface" app-crypt/pinentry[efl]
+ optfeature "better monitor backlight and brightness controls" app-misc/ddcutil
+ optfeature "office file thumbnails" app-office/libreoffice app-office/libreoffice-bin
+ optfeature "an EFL-based IDE" dev-util/edi
+ optfeature "image viewer" media-gfx/ephoto
+ optfeature "ConnMan user interface for Enlightenment" net-misc/econnman
+ optfeature "system and process monitor" sys-process/evisum
+ optfeature "feature rich terminal emulator" x11-terms/terminology
+ optfeature "a modern flat enlightenment WM theme" x11-themes/e-flat-theme
+ optfeature "a matching GTK theme" x11-themes/e-gtk-theme
+}