summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2021-07-12 09:24:53 +0200
committerFlorian Schmaus <flow@gentoo.org>2021-07-12 09:24:53 +0200
commit1fa0ed9fd7fb3abbd6b2fd5f7f6b6ec638742bf7 (patch)
treeaa22f8b492ea95d270507f71d04bd6cef389a7b6 /x11-wm
parentprofiles/arch: mask dev-util/diffoscope[haskell] everywhere but amd64/x86 (diff)
downloadgentoo-1fa0ed9fd7fb3abbd6b2fd5f7f6b6ec638742bf7.tar.gz
gentoo-1fa0ed9fd7fb3abbd6b2fd5f7f6b6ec638742bf7.tar.bz2
gentoo-1fa0ed9fd7fb3abbd6b2fd5f7f6b6ec638742bf7.zip
x11-wm/herbstluftwm: use distutils_install_for_testing in src_test
Bug: https://bugs.gentoo.org/801658 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/herbstluftwm/herbstluftwm-0.9.3.ebuild7
-rw-r--r--x11-wm/herbstluftwm/herbstluftwm-9999.ebuild7
2 files changed, 14 insertions, 0 deletions
diff --git a/x11-wm/herbstluftwm/herbstluftwm-0.9.3.ebuild b/x11-wm/herbstluftwm/herbstluftwm-0.9.3.ebuild
index 65e8342992a3..fe478ccf2e52 100644
--- a/x11-wm/herbstluftwm/herbstluftwm-0.9.3.ebuild
+++ b/x11-wm/herbstluftwm/herbstluftwm-0.9.3.ebuild
@@ -129,5 +129,12 @@ distutils_enable_tests pytest
src_test() {
ln -s "${BUILD_DIR}/herbstclient" || die "Could not symlink herbstclient"
ln -s "${BUILD_DIR}/herbstluftwm" || die "Could not symlink herbstluftwm"
+
+ pushd python > /dev/null || die
+ distutils_install_for_testing
+ popd > /dev/null || die
+
+ # Ensure PYTHONPATH is exported, see https://bugs.gentoo.org/801658.
+ export PYTHONPATH
python_test
}
diff --git a/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild b/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
index c167e7f353e2..37035a6a5ff8 100644
--- a/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
+++ b/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
@@ -129,5 +129,12 @@ distutils_enable_tests pytest
src_test() {
ln -s "${BUILD_DIR}/herbstclient" || die "Could not symlink herbstclient"
ln -s "${BUILD_DIR}/herbstluftwm" || die "Could not symlink herbstluftwm"
+
+ pushd python > /dev/null || die
+ distutils_install_for_testing
+ popd > /dev/null || die
+
+ # Ensure PYTHONPATH is exported, see https://bugs.gentoo.org/801658.
+ export PYTHONPATH
python_test
}