summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2023-12-23 22:05:20 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-12-23 22:05:55 +0200
commit248ca4e89aced85c1f4b9ef397d3794f24f4d524 (patch)
treebd9fdd2789997f728b11d370e6e556b2de20c698 /x11-wm
parentdev-libs/efl: add 1.27.0 (diff)
downloadgentoo-248ca4e89aced85c1f4b9ef397d3794f24f4d524.tar.gz
gentoo-248ca4e89aced85c1f4b9ef397d3794f24f4d524.tar.bz2
gentoo-248ca4e89aced85c1f4b9ef397d3794f24f4d524.zip
x11-wm/enlightenment: add 0.26.0
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/enlightenment/Manifest1
-rw-r--r--x11-wm/enlightenment/enlightenment-0.26.0.ebuild119
2 files changed, 120 insertions, 0 deletions
diff --git a/x11-wm/enlightenment/Manifest b/x11-wm/enlightenment/Manifest
index a4d9f9e09b10..8dd92964ac84 100644
--- a/x11-wm/enlightenment/Manifest
+++ b/x11-wm/enlightenment/Manifest
@@ -1 +1,2 @@
DIST enlightenment-0.25.4.tar.xz 405709440 BLAKE2B cf61ee65dc20b5815b12cf8dd5576c566ee6ab83a41dc4e133c71dd72301283f2eda37f75328364b4ffb66851ec5801d996e71551f695aea43f3f0e5f81ad84b SHA512 7f43df7721b0440e49bc9b22e2376e73a7a8fb88968edb7efee6d9e19d39c140efe0bb1ab6069d9aafbf1a4231852c38da807a10338cfa7d0e48f2a0d3a6b284
+DIST enlightenment-0.26.0.tar.xz 409678784 BLAKE2B e03cb4485fafd3b03a69ca20b5910fc5b0d7070b625a5f9f6c365d57b62b6be00f7c370f38e127e92f29e430045c3502e7868219cb246f84f044d418808a3ae1 SHA512 52a656b397348a4f6baa28b9da4b42c81160b06d28dba58c22bdf00bf749aed3a9b194e171a5ac349745a4c11afc8ae8c38f9bf8c31bacbc0d196cfb24b15a1e
diff --git a/x11-wm/enlightenment/enlightenment-0.26.0.ebuild b/x11-wm/enlightenment/enlightenment-0.26.0.ebuild
new file mode 100644
index 000000000000..4d193dd7c892
--- /dev/null
+++ b/x11-wm/enlightenment/enlightenment-0.26.0.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature xdg
+
+DESCRIPTION="Enlightenment window manager"
+HOMEPAGE="https://www.enlightenment.org"
+SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+
+# Historically enlightenment was slotted to separate e16 from e17. e16 is now
+# packaged as x11-wm/e16, but the slot is kept because it's more complicated to
+# reset it rather than just to keep it.
+SLOT="0.17/${PV%%_*}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="acpi bluetooth connman doc exif geolocation nls pam policykit systemd udisks wayland xwayland"
+
+REQUIRED_USE="xwayland? ( wayland )"
+
+RDEPEND=">=dev-libs/efl-1.27.0[eet,fontconfig,sound,X]
+ virtual/udev
+ x11-libs/libXext
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+ x11-misc/xkeyboard-config
+ acpi? ( sys-power/acpid )
+ bluetooth? ( net-wireless/bluez )
+ connman? ( dev-libs/efl[connman] )
+ exif? ( media-libs/libexif )
+ geolocation? ( app-misc/geoclue:2.0 )
+ pam? ( sys-libs/pam )
+ policykit? ( sys-auth/polkit )
+ systemd? ( sys-apps/systemd )
+ udisks? ( sys-fs/udisks:2 )
+ wayland? (
+ || (
+ dev-libs/efl[systemd]
+ dev-libs/efl[elogind]
+ )
+ dev-libs/efl[drm,wayland]
+ dev-libs/wayland
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ )
+ xwayland? (
+ dev-libs/efl[X,wayland]
+ x11-base/xwayland
+ )"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ -D device-udev=true
+ -D elput=true
+ -D install-enlightenment-menu=true
+
+ -D install-sysactions=true
+ -D install-system=true
+ -D mount-eeze=false
+
+ -D packagekit=false
+
+ $(meson_use udisks mount-udisks)
+ $(meson_use bluetooth bluez5)
+ $(meson_use connman)
+ $(meson_use exif libexif)
+ $(meson_use geolocation)
+ $(meson_use nls)
+ $(meson_use pam)
+ $(meson_use policykit polkit)
+ $(meson_use systemd)
+ $(meson_use wayland wl)
+ $(meson_use xwayland)
+ )
+
+ if ! use wayland; then
+ emesonargs+=(
+ -D wl-buffer=false
+ -D wl-desktop-shell=false
+ -D wl-drm=false
+ -D wl-text-input=false
+ -D wl-weekeyboard=false
+ -D wl-wl=false
+ -D wl-x11=false
+ )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/. )
+ meson_src_install
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+
+ optfeature_header "Additional programs to complement the full EFL suite:"
+ optfeature "efl-based pinentry interface" app-crypt/pinentry[efl]
+ optfeature "an efl-based text editor" app-editors/ecrire
+ optfeature "better monitor backlight and brightness controls" app-misc/ddcutil
+ optfeature "office file thumbnails" app-office/libreoffice app-office/libreoffice-bin
+ optfeature "an EFL-based IDE" dev-util/edi
+ optfeature "image viewer" media-gfx/entice
+ optfeature "image viewer" media-gfx/ephoto
+ optfeature "a media player" media-video/rage
+ optfeature "ConnMan user interface for Enlightenment" net-misc/econnman
+ optfeature "system and process monitor" sys-process/evisum
+ optfeature "feature rich terminal emulator" x11-terms/terminology
+ optfeature "a matching GTK theme" x11-themes/e-gtk-theme
+}