summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2021-06-10 09:09:49 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2021-06-30 18:41:43 -0400
commit7107ac7493795da71bd81c61d54ebc8e974c6e46 (patch)
treeb4417041c7b4445e51416fbf91bf50596f176c91 /x11-wm
parentmate-base/caja: Bump to 1.24.1 (diff)
downloadgentoo-7107ac7493795da71bd81c61d54ebc8e974c6e46.tar.gz
gentoo-7107ac7493795da71bd81c61d54ebc8e974c6e46.tar.bz2
gentoo-7107ac7493795da71bd81c61d54ebc8e974c6e46.zip
x11-wm/marco: Bump to 1.24.2
Bug: https://bugs.gentoo.org/778857 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/marco/Manifest1
-rw-r--r--x11-wm/marco/marco-1.24.2.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/x11-wm/marco/Manifest b/x11-wm/marco/Manifest
index 209ca943e262..8e8619685918 100644
--- a/x11-wm/marco/Manifest
+++ b/x11-wm/marco/Manifest
@@ -1 +1,2 @@
DIST marco-1.24.1.tar.xz 1860008 BLAKE2B b147e6ce8aad9382b2e8d96eec2da0356cce91977f4387776359ffb1f26903d7f0b9d9a1d43a436d1a64033f545600e7f810a29e3ae6ecdfb0d73ef8073b782c SHA512 55607898b64f0da3a85dd8d7fd092d847c8f67cefa096a63dbe074c197157a3d661fcb3f2a495b4425340b583b600cda3d1c92ac08b7327904dbd4aab8e92c85
+DIST marco-1.24.2.tar.xz 1845356 BLAKE2B 9308e07fec5319f741f7d78007e68e916c407c515fc2076c0e26a760830d3c79edf39888f265f7edc1baf0c8dc29661fb6598be16352103455cc441bc2a1daf5 SHA512 2e699935fb72ddc34aa1f98f5771f252141245ad8fd0983aafe5ea55aeeb3f90b5d68a61c27704adf0b929565180367aae46486d45e789d7de101ec9a7bc9f96
diff --git a/x11-wm/marco/marco-1.24.2.ebuild b/x11-wm/marco/marco-1.24.2.ebuild
new file mode 100644
index 000000000000..e36ea8196cc3
--- /dev/null
+++ b/x11-wm/marco/marco-1.24.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE2_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="MATE default window manager"
+LICENSE="FDL-1.2+ GPL-2+ LGPL-2+ MIT"
+SLOT="0/2"
+
+IUSE="startup-notification test xinerama"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-libs/atk
+ >=dev-libs/glib-2.58:2
+ >=gnome-base/libgtop-2:2=
+ media-libs/libcanberra[gtk3]
+ x11-libs/cairo
+ >=x11-libs/pango-1.2[X]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ >=x11-libs/libXcomposite-0.3
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXpresent
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ >=x11-libs/startup-notification-0.7
+ xinerama? ( x11-libs/libXinerama )
+ !!x11-wm/mate-window-manager
+"
+
+RDEPEND="${COMMON_DEPEND}
+ gnome-extra/zenity
+ >=mate-base/mate-desktop-1.20.0
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ >=sys-devel/gettext-0.19.8
+ >=sys-devel/libtool-2.0.0
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ xinerama? ( x11-base/xorg-proto )
+"
+
+src_configure() {
+ mate_src_configure \
+ --enable-compositor \
+ --enable-render \
+ --enable-shape \
+ --enable-sm \
+ --enable-xsync \
+ $(use_enable startup-notification) \
+ $(use_enable xinerama)
+}
+
+src_install() {
+ mate_src_install
+ dodoc doc/*.txt
+}