summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2020-03-03 16:17:52 -0500
committerAdam Feldman <NP-Hardass@gentoo.org>2020-04-06 13:47:29 -0400
commit770703a36d97586fdc9ca917f4edcf40fda4fe9a (patch)
treef93cc67e02e5480b33c4ce6660f0dc82e9264fb7 /x11-wm
parentmate-base/caja: Bump 1.22.3 (diff)
downloadgentoo-770703a36d97586fdc9ca917f4edcf40fda4fe9a.tar.gz
gentoo-770703a36d97586fdc9ca917f4edcf40fda4fe9a.tar.bz2
gentoo-770703a36d97586fdc9ca917f4edcf40fda4fe9a.zip
x11-wm/marco: Bump to 1.22.4
Package-Manager: Portage-2.3.82, Repoman-2.3.18 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/marco/Manifest1
-rw-r--r--x11-wm/marco/marco-1.22.4.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/x11-wm/marco/Manifest b/x11-wm/marco/Manifest
index 5739f73502b4..6efbb8b06986 100644
--- a/x11-wm/marco/Manifest
+++ b/x11-wm/marco/Manifest
@@ -1,2 +1,3 @@
DIST marco-1.22.1.tar.xz 1357864 BLAKE2B 241e71795acfdcbf90070ef0d14f0cc55894a5cddbf48bd8741cf9580cfcaa035890b23a2182738875ce4d89d099a80d59aa7b1937e4a34a18a5a969830e7db9 SHA512 18093f4d419fbc90f957a04ec3e36a153b3c51a6bcdc1ac5884adcc0292f157bc5e4af51e171451a4b54b5bccffdee2e8a07ed13dafb6106773abfb06b6a8a4f
DIST marco-1.22.2.tar.xz 1366104 BLAKE2B 6caa7da12c32b8adcc6d3ab4525fcf9e892585cb528bd73e47af1e2eeda2c31d174e55acd98f9a4759e22176fa06aa13d8a6ef6a6b2cc82d11bed27b156d6739 SHA512 96665120dbc698c78795eeaa559ae2bfd2a3c7ed4846e40bcfb1d6dfc8d7e359b860e1e715085a17e11c66ce7f31561d372da8372209c21c7b1ce6029a3f5ea1
+DIST marco-1.22.4.tar.xz 1368868 BLAKE2B 45a1bdfa13419f690e4a1604a18f1ef4f57b95cc64c628a8d1c4b8d5a92409eb8ecb946b60c9b9711151858a4668247f2ee031a95464463f3005952edd95265c SHA512 46867396b66453c63624e54c382845b898b10768db0560100f021e57ec80189785093be38eeaf19c50a9e4728de2b6e605267a8f1d5a5596aaa75958c0e3a6b0
diff --git a/x11-wm/marco/marco-1.22.4.ebuild b/x11-wm/marco/marco-1.22.4.ebuild
new file mode 100644
index 000000000000..945631316fd8
--- /dev/null
+++ b/x11-wm/marco/marco-1.22.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE2_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="MATE default window manager"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="startup-notification test xinerama"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-libs/atk
+ >=dev-libs/glib-2.50:2
+ >=gnome-base/libgtop-2:2=
+ media-libs/libcanberra[gtk3]
+ x11-libs/cairo
+ >=x11-libs/pango-1.2[X]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ >=x11-libs/libXcomposite-0.3
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXpresent
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ >=x11-libs/startup-notification-0.7
+ virtual/libintl
+ xinerama? ( x11-libs/libXinerama )
+ !!x11-wm/mate-window-manager"
+
+RDEPEND="${COMMON_DEPEND}
+ gnome-extra/zenity
+ >=mate-base/mate-desktop-1.20.0"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.34.90
+ sys-devel/gettext:*
+ virtual/pkgconfig:*
+ x11-base/xorg-proto
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ xinerama? ( x11-base/xorg-proto )"
+
+src_configure() {
+ mate_src_configure \
+ --enable-compositor \
+ --enable-render \
+ --enable-shape \
+ --enable-sm \
+ --enable-xsync \
+ $(use_enable startup-notification) \
+ $(use_enable xinerama)
+}
+
+src_install() {
+ mate_src_install
+ dodoc {,doc/}*.txt
+}