summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-04-14 11:04:34 -0400
committerJoonas Niilola <juippis@gentoo.org>2021-04-15 09:38:59 +0300
commit8d84aa93208cea5c8681efd950a5b57f69ef9675 (patch)
treeed2308b61ca6b505ef4b829d36fc8fe63738370c /x11-wm
parentx11-wm/lwm: fix build with -native-symlinks (diff)
downloadgentoo-8d84aa93208cea5c8681efd950a5b57f69ef9675.tar.gz
gentoo-8d84aa93208cea5c8681efd950a5b57f69ef9675.tar.bz2
gentoo-8d84aa93208cea5c8681efd950a5b57f69ef9675.zip
x11-wm/vtwm: fix build with -native-symlinks
Also swapped DEPEND with BDEPEND to put imake in the right block. Closes: https://bugs.gentoo.org/726210 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/20381 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/vtwm/vtwm-5.4.7-r2.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/x11-wm/vtwm/vtwm-5.4.7-r2.ebuild b/x11-wm/vtwm/vtwm-5.4.7-r2.ebuild
index e2c87e29d8c8..67ac8de4a833 100644
--- a/x11-wm/vtwm/vtwm-5.4.7-r2.ebuild
+++ b/x11-wm/vtwm/vtwm-5.4.7-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,12 +20,13 @@ RDEPEND="x11-libs/libX11
x11-libs/libXext
x11-libs/libXpm
rplay? ( media-sound/rplay )"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
app-text/rman
sys-devel/bison
sys-devel/flex
x11-base/xorg-proto
- x11-misc/imake"
+ >=x11-misc/imake-1.0.8-r1"
src_prepare() {
eapply "${FILESDIR}"/${P}-do-not-rm.patch
@@ -45,14 +46,14 @@ src_prepare() {
}
src_configure() {
- xmkmf || die "xmkmf failed"
- emake depend
+ CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
+ IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf -a || die "xmkmf failed"
}
src_compile() {
emake \
- CC=$(tc-getCC) \
- CCOPTIONS="${CFLAGS}" \
+ CC="$(tc-getCC)" \
+ CDEBUGFLAGS="${CFLAGS}" \
EXTRA_LDOPTIONS="${LDFLAGS}"
}