summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2019-10-10 11:36:07 -0500
committerBen Kohler <bkohler@gentoo.org>2019-10-10 11:36:50 -0500
commit9fd22426f7967bfd0cef7cc70ae9024b3c90932d (patch)
treebc0a8c21b8b0421fd228597cb1a0bfa6d7a5c72e /x11-wm
parentsys-apps/pcsc-lite: Provide systemd-aware udev rule (diff)
downloadgentoo-9fd22426f7967bfd0cef7cc70ae9024b3c90932d.tar.gz
gentoo-9fd22426f7967bfd0cef7cc70ae9024b3c90932d.tar.bz2
gentoo-9fd22426f7967bfd0cef7cc70ae9024b3c90932d.zip
x11-wm/blackbox: take package & bump to 0.75
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/blackbox/Manifest1
-rw-r--r--x11-wm/blackbox/blackbox-0.75.ebuild52
-rw-r--r--x11-wm/blackbox/metadata.xml7
3 files changed, 58 insertions, 2 deletions
diff --git a/x11-wm/blackbox/Manifest b/x11-wm/blackbox/Manifest
index 491709de1857..af8a9a7ea1c8 100644
--- a/x11-wm/blackbox/Manifest
+++ b/x11-wm/blackbox/Manifest
@@ -1 +1,2 @@
DIST blackbox-0.70.1.tar.bz2 492399 BLAKE2B d6faed388d2a1fbfbf10baf2b848f78fc5d99bc4e5fb2daf28df7ec9732d9ad5de9dfa87763cea9a954ed72b23207563dda65c92bb37ba2136e8f6e6049e0ab7 SHA512 6e8cf6fd04030a5f97ffd8dbe97aaa0f683f776e7237cdd46f2b93265cd8de665cffce5a352624a2235aa6c42628be13f98d565af765b3f06e95bff404fb0ccb
+DIST blackbox-0.75.tar.gz 394605 BLAKE2B 6e1338f946fe1d211d88f060178a17c452ca2b5f700d8ab73c62e2f01fd7bc81a52d06dcb42941c133528b144a6707c6ecc4711cb10630ce2921214d0b699669 SHA512 64d1ec45f9cb143dc5e3688a490acb3e20e303c57f778656dda227215b2fa13ca2db753aebc7b1ea9605a9d66c69ff8cfdf8010dc2f37ddc4609d9d3865ec068
diff --git a/x11-wm/blackbox/blackbox-0.75.ebuild b/x11-wm/blackbox/blackbox-0.75.ebuild
new file mode 100644
index 000000000000..6ee20fa6ed18
--- /dev/null
+++ b/x11-wm/blackbox/blackbox-0.75.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A small, fast, full-featured window manager for X"
+HOMEPAGE="https://github.com/bbidulock/blackboxwm"
+SRC_URI="https://github.com/bbidulock/blackboxwm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="nls truetype debug"
+
+RDEPEND="x11-libs/libXft
+ x11-libs/libXt
+ nls? ( sys-devel/gettext )
+ truetype? ( media-libs/freetype )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"/blackboxwm-${PV}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/X11/${PN} \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable truetype xft)
+}
+
+src_install() {
+ dodir /etc/X11/Sessions
+ echo "/usr/bin/blackbox" > "${D}/etc/X11/Sessions/${PN}"
+ fperms a+x /etc/X11/Sessions/${PN}
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}/${PN}.desktop"
+
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog* COMPLIANCE README* TODO
+
+ prune_libtool_files --all
+}
diff --git a/x11-wm/blackbox/metadata.xml b/x11-wm/blackbox/metadata.xml
index 5d2ee1af2e01..4897d4fba49e 100644
--- a/x11-wm/blackbox/metadata.xml
+++ b/x11-wm/blackbox/metadata.xml
@@ -1,13 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>bkohler@gentoo.org</email>
+ <name>Ben Kohler</name>
+ </maintainer>
<longdescription>
Blackbox is that fast, light window manager you have been looking for
without all those annoying library dependencies. If you have a C++
compiler and the X Window System you can compile and use it.
</longdescription>
<upstream>
- <remote-id type="sourceforge">blackboxwm</remote-id>
+ <remote-id type="github">bbidulock/blackboxwm</remote-id>
</upstream>
</pkgmetadata>