summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-01 09:11:14 -0400
committerMatt Turner <mattst88@gentoo.org>2021-05-01 09:34:38 -0400
commitcb6e8e5fe3ff3eb42b137e08062b9c84a5723fd6 (patch)
tree37e5d77db7c17f77a2df20959c6d7ad66920b5b6 /x11-wm
parentx11-libs/vte: use ${EPYTHON}, not python3 (diff)
downloadgentoo-cb6e8e5fe3ff3eb42b137e08062b9c84a5723fd6.tar.gz
gentoo-cb6e8e5fe3ff3eb42b137e08062b9c84a5723fd6.tar.bz2
gentoo-cb6e8e5fe3ff3eb42b137e08062b9c84a5723fd6.zip
x11-wm/metacity: Version bump to 3.40.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/metacity/Manifest1
-rw-r--r--x11-wm/metacity/metacity-3.40.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-wm/metacity/Manifest b/x11-wm/metacity/Manifest
index 104d7a4c8d57..098bb26fefa7 100644
--- a/x11-wm/metacity/Manifest
+++ b/x11-wm/metacity/Manifest
@@ -1 +1,2 @@
DIST metacity-3.36.1.tar.xz 2063452 BLAKE2B 2dd7b1c63e0b5f87ce4518d7d42d472223717012a46dd826dfda3c88f7e647809e6bf2449a28bd38573342fd5fec94e2233db958658ea4320b22c5451390e451 SHA512 98e73036cca238b713a112194b2cd7a866bcf7d08ef29fb590054b69a1bd807699317a51f9b851f9c474ae2557e27dc9fc4a52d7c436d93ad4a02babef68feeb
+DIST metacity-3.40.0.tar.xz 1970260 BLAKE2B 4ccd38b0ceaeef7145d28b1f4e579aebe75e1506af8097e97e5422f39e04ae9d1e259f17cc08dc68fe71d4eb082311c736dbcfafb4a3a775f6ddcce5ce77b859 SHA512 f9eeb0b08bb302c5fb0d174a4df97b253255741d507e94200820d3ebe9e89f179c9096b8e56798836fc84cbe1ac76b27fee6762f3d41373280c4726bc7cba2ff
diff --git a/x11-wm/metacity/metacity-3.40.0.ebuild b/x11-wm/metacity/metacity-3.40.0.ebuild
new file mode 100644
index 000000000000..590fac68d685
--- /dev/null
+++ b/x11-wm/metacity/metacity-3.40.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2
+
+DESCRIPTION="GNOME Flashback window manager"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/metacity/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+libcanberra vulkan xinerama"
+KEYWORDS="~amd64"
+
+# TODO: libgtop could be optional, but no knob
+RDEPEND="
+ >=dev-libs/glib-2.67.3:2
+ >=x11-libs/gtk+-3.22.0:3[X]
+ >=x11-libs/pango-1.2.0
+ >=x11-libs/libXcomposite-0.3
+ >=gnome-base/gsettings-desktop-schemas-3.3.0
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXdamage
+ x11-libs/libXres
+ x11-libs/libXpresent
+ libcanberra? ( media-libs/libcanberra[gtk3] )
+ >=x11-libs/startup-notification-0.7
+ x11-libs/libXcursor
+ gnome-base/libgtop:2=
+ x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )
+ x11-libs/libXrandr
+ x11-libs/libXext
+ x11-libs/libICE
+ x11-libs/libSM
+ gnome-extra/zenity
+ vulkan? ( media-libs/vulkan-loader )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ vulkan? ( dev-util/vulkan-headers )
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+" # autoconf-archive for eautoreconf
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable libcanberra canberra) \
+ $(use_enable xinerama) \
+ $(use_enable vulkan)
+}