summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-07-17 07:45:15 +0200
committerHans de Graaff <graaff@gentoo.org>2021-07-18 06:48:19 +0200
commite30ca5a5734f147863058c02f2e1eb41d137a308 (patch)
tree6b32b74140c41161fd72df53101e0f64add15e4d /x11-wm
parentapp-editors/diakonos: add ruby27, ruby30; EAPI 7 (diff)
downloadgentoo-e30ca5a5734f147863058c02f2e1eb41d137a308.tar.gz
gentoo-e30ca5a5734f147863058c02f2e1eb41d137a308.tar.bz2
gentoo-e30ca5a5734f147863058c02f2e1eb41d137a308.zip
x11-wm/subtle: drop live ebuild for unmaintained package
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/subtle/subtle-9999.ebuild89
1 files changed, 0 insertions, 89 deletions
diff --git a/x11-wm/subtle/subtle-9999.ebuild b/x11-wm/subtle/subtle-9999.ebuild
deleted file mode 100644
index ef71c3fce45f..000000000000
--- a/x11-wm/subtle/subtle-9999.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-USE_RUBY="ruby24 ruby25 ruby26"
-
-inherit ruby-ng toolchain-funcs
-
-if [[ ${PV} == "9999" ]]; then
- EHG_REPO_URI="https://hg.subforge.org/subtle"
- EHG_CHECKOUT_DIR=${S}/all
- inherit mercurial
-else
- SRC_URI="https://dev.gentoo.org/~radhermit/dist/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="A manual tiling window manager"
-HOMEPAGE="https://subforge.org/projects/subtle/wiki"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="debug doc +xft xinerama xpm +xrandr +xtest"
-RESTRICT="!test? ( test )"
-
-RDEPEND="x11-libs/libX11
- xft? ( x11-libs/libXft )
- xinerama? ( x11-libs/libXinerama )
- xpm? ( x11-libs/libXpm )
- xtest? ( x11-libs/libXtst )
- xrandr? ( x11-libs/libXrandr )"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-ruby_add_rdepend "dev-ruby/archive-tar-minitar"
-ruby_add_bdepend "dev-ruby/rake doc? ( dev-ruby/rdoc )"
-
-all_ruby_unpack() {
- if [[ ${PV} == "9999" ]]; then
- mercurial_src_unpack
- else
- default
- fi
-}
-
-each_ruby_configure() {
- local myconf
- use debug && myconf+=" debug=yes" || myconf+=" debug=no"
- use xft && myconf+=" xft=yes" || myconf+=" xft=no"
- use xinerama && myconf+=" xinerama=yes" || myconf+=" xinerama=no"
- use xpm && myconf+=" xpm=yes" || myconf+=" xpm=no"
- use xtest && myconf+=" xtest=yes" || myconf+=" xtest=no"
- use xrandr && myconf+=" xrandr=yes" || myconf+=" xrandr=no"
-
- ${RUBY} -S rake -v CC="$(tc-getCC)" destdir="${D}" ${myconf} config || die
-}
-
-each_ruby_compile() {
- ${RUBY} -S rake -v build || die
-}
-
-all_ruby_compile() {
- use doc && { rake rdoc || die ; }
-}
-
-each_ruby_install() {
- ${RUBY} -S rake -v install || die
-}
-
-all_ruby_install() {
- dodir /etc/X11/Sessions
- cat <<-EOF > "${D}/etc/X11/Sessions/${PN}"
- #!/bin/sh
- exec /usr/bin/subtle
- EOF
- fperms a+x /etc/X11/Sessions/${PN}
-
- insinto /usr/share/xsessions
- doins data/${PN}.desktop
-
- dodoc AUTHORS NEWS
-
- use doc && dodoc -r html
-}
-
-pkg_postinst() {
- elog "Note that surserver will currently not work since dev-ruby/datamapper"
- elog "is not in the tree."
-}